Announcement

Collapse
No announcement yet.

Performance Optimizations For KDE's KWin 4.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Performance Optimizations For KDE's KWin 4.6

    Phoronix: Performance Optimizations For KDE's KWin 4.6

    While some developers and other KDE contributors are busy voicing their opinions over merging the KDE libraries into the upstream Qt, which would lead to either KDE 5.0 or KDE 6.0 depending upon how it's implemented and if it's actually carried out, KDE Software Compilation 4.6 is still on the way and should officially arrive by the end of January. Martin Graesslin, who works on much of the KWin compositing manager and previously said KDE SC 4.7 may support OpenGL 3.x for compositing, has written about some of the KWin changes for KDE 4.6...

    http://www.phoronix.com/vr.php?view=ODc0Mg

  • #2
    I like what I'm reading here. Hopefully, the 4.5-4.6 optimizations work better for me than the 4.4-4.5 optimizations do. As it stands, I cannot currently use compositing without the menu causing the screen to flicker.

    Comment


    • #3
      All I can say is: thank $DEITY. KWin 4.5 was a big step backward for folks like me that dared to use anything other than, what, the Proprietary nVidia Driver. I'm using the latest and greatest built-from-Git xf86-video-ati drivers and can only really use XRender-based compositing. In 4.4, OpenGL worked fine.

      Comment


      • #4
        Originally posted by siride View Post
        All I can say is: thank $DEITY. KWin 4.5 was a big step backward for folks like me that dared to use anything other than, what, the Proprietary nVidia Driver. I'm using the latest and greatest built-from-Git xf86-video-ati drivers and can only really use XRender-based compositing. In 4.4, OpenGL worked fine.
        Are you sure the Lanczos and Blur filters are properly blacklisted for your drivers/Mesa version in KWin? By default they are only blacklisted for Mesa 7.8.1 and 7.8.2 (KDE SC 4.5.1).

        And if there are some problems with not being able to try the OpenGL renderer at all in systemsettings, you might want to change OpenGLIsUnsafe to 'false' in your kwinrc file and restart KWin. This seemed to be some strange left-over of a previous KWin check, as testing with a fresh user gave no problems.

        I had some problems too (with Mesa 7.9, xf86-video-ati-6.13.x, xorg-server 1.9.x) and this fixed it for me (both not being able to enable OpenGL at all and horrible performance with some specific effects)

        Comment


        • #5
          ^^ Try upgrading the driver stack and removing kwinrc.

          KWin effects and Blur have been working on my r700 for quite a while now.

          Comment


          • #6
            Originally posted by siride View Post
            All I can say is: thank $DEITY. KWin 4.5 was a big step backward for folks like me that dared to use anything other than, what, the Proprietary nVidia Driver. I'm using the latest and greatest built-from-Git xf86-video-ati drivers and can only really use XRender-based compositing. In 4.4, OpenGL worked fine.
            You're not missing much. Kwin 4.5 is a step backwards even with the nvidia driver for me.

            Comment


            • #7
              Another interesting blog by Martin:
              http://blog.martin-graesslin.com/blo...0/kwin-at-uds/

              Canonical is also aware of the driver regressions we run into our latest release. The hardware requirements for Unity are slightly higher than ours. Unity requires Framebuffer Objects (FBO), which we use in various effects (e.g. Blur). Canonical will set up a great testing environment to ensure that the quality of drivers does not regress.
              Hopefully Canonical will put some manpower behind driver development...

              Comment


              • #8
                Originally posted by Zapp! View Post
                Hopefully Canonical will put some manpower behind driver development...
                Yeah, right....

                Comment


                • #9
                  Originally posted by siride View Post
                  All I can say is: thank $DEITY. KWin 4.5 was a big step backward for folks like me that dared to use anything other than, what, the Proprietary nVidia Driver. I'm using the latest and greatest built-from-Git xf86-video-ati drivers and can only really use XRender-based compositing. In 4.4, OpenGL worked fine.
                  Then use KWin 4.4. What's the problem? At least in openSUSE it's very simple. Just select KWin from the 4.4 repository (in openSUSE 11.3 KWin 4.4 is available in the regular Updates repo) and lock KWin's package to stay at 4.4 when you perform upgrades.
                  The whole process is done after only 5 or so mouse clicks.

                  Comment


                  • #10
                    Originally posted by drelyn86 View Post
                    You're not missing much. Kwin 4.5 is a step backwards even with the nvidia driver for me.
                    Maybe it wasn't the nVidia driver. There was some driver that actually worked with KWin 4.5's "performance" "improvements". The open source drivers certainly got shat upon.

                    Comment

                    Working...
                    X