Announcement

Collapse
No announcement yet.

KDE Plasma 6.1 Prepares For Release Next Week

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • KDE Plasma 6.1 Prepares For Release Next Week

    Phoronix: KDE Plasma 6.1 Prepares For Release Next Week

    KDE Plasma 6.1 is preparing for release next week on 18 June. KDE developers this week have thus been very busy with last minute finishing touches to this updated desktop while also already beginning feature work on Plasma 6.2...

    Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux server benchmarks, Linux benchmarking, Desktop Linux, Linux performance, Open Source graphics, Linux How To, Ubuntu benchmarks, Ubuntu hardware, Phoronix Test Suite

  • #2
    There's a typo in the link to Nate's blog (/a at the end) which makes it redirect to a super old post on the site.

    Comment


    • #3
      Just upgraded from Plasma 5 to Plasma 6.1 beta, but with Wayland the mouse cursor is extremely choppy and stuttery. Switched back to X11. Nvidia driver 555.52.04.

      Comment


      • #4
        Originally posted by RealNC View Post
        Just upgraded from Plasma 5 to Plasma 6.1 beta, but with Wayland the mouse cursor is extremely choppy and stuttery. Switched back to X11. Nvidia driver 555.52.04.
        Most of the time, the solution is easy. It's all over the Internet, Reddit, etc. I'm guessing you have a new 2000 series GPU or newer, right?
        If so, turn off the "firmware".

        Comment


        • #5
          Originally posted by Rovano View Post

          Most of the time, the solution is easy. It's all over the Internet, Reddit, etc. I'm guessing you have a new 2000 series GPU or newer, right?
          If so, turn off the "firmware".
          Thanks. I did search for this, but got no results. I assume you mean the GSP firmware. So I disabled it:

          Code:
          options nvidia \
              NVreg_EnableGpuFirmware=0​
          Rebooted and verified that it's indeed disabled:

          Code:
          $ nvidia-smi -q | grep -i gsp
          GSP Firmware Version : N/A​
          Didn't help at all. Mouse cursor is still as choppy as before. It's like the mouse cursor moves at 30Hz or something (display is at 120Hz.)​

          Comment


          • #6
            Originally posted by RealNC View Post

            Thanks. I did search for this, but got no results. I assume you mean the GSP firmware. So I disabled it:

            Code:
            options nvidia \
            NVreg_EnableGpuFirmware=0​
            Rebooted and verified that it's indeed disabled:

            Code:
            $ nvidia-smi -q | grep -i gsp
            GSP Firmware Version : N/A​
            Didn't help at all. Mouse cursor is still as choppy as before. It's like the mouse cursor moves at 30Hz or something (display is at 120Hz.)​
            Damn it. I'm sorry it didn't work. What distribution is this?
            Do you have a patched Kwin version or the new Wayland, XWayland packages?
            Last edited by Rovano; 15 June 2024, 09:22 AM.

            Comment


            • #7
              Originally posted by Rovano View Post
              Damn it. I'm sorry it didn't work. What distribution is this?
              Gentoo.

              However, I suspect it's due to VRR shenanigans. If I run glxgears so that something is drawn on the screen at a high frame rate, mouse cursor becomes smooth. As soon as I quit glxgears, mouse becomes a stutter fest again.

              Unfortunately, I cannot disable g-sync to test this, because the nvidia settings control panel doesn't work in wayland.

              I'm not sure whoever implemented this behavior thought things through... :P

              Do you have a patched Kwin version or the new Wayland, XWayland packages?
              I didn't patch anything manually. I installed the distro versions:

              kwin 6.0.90.1
              wayland 1.23.0
              xwayland 24.1.0
              Last edited by RealNC; 15 June 2024, 09:29 AM.

              Comment


              • #8
                Originally posted by RealNC View Post

                Gentoo.

                However, I suspect it's due to VRR shenanigans. If I run glxgears so that something is drawn on the screen at a high frame rate, mouse cursor becomes smooth. As soon as I quit glxgears, mouse becomes a stutter fest again.

                Unfortunately, I cannot disable g-sync to test this, because the nvidia settings control panel doesn't work in wayland.

                I'm not sure whoever implemented this behavior thought things through... :P
                AMD cards do it too. Don't worry about missing out. Does Gentoo still have Tux visible on boot? I have a feeling that this was removed with the development of the kernel.
                There was a time when I at least had Sabayon. Oh the compilation days. But how it sizzled afterwards!

                Comment


                • #9
                  Originally posted by Rovano View Post
                  AMD cards do it too. Don't worry about missing out.
                  Really? How is this not a complete showstopper for people?

                  Does Gentoo still have Tux visible on boot? I have a feeling that this was removed with the development of the kernel.
                  There was a time when I at least had Sabayon. Oh the compilation days. But how it sizzled afterwards!
                  No tux logo. But I had it disabled myself for ages now anyway.

                  Comment


                  • #10
                    Originally posted by RealNC View Post

                    Gentoo.

                    However, I suspect it's due to VRR shenanigans. If I run glxgears so that something is drawn on the screen at a high frame rate, mouse cursor becomes smooth. As soon as I quit glxgears, mouse becomes a stutter fest again.

                    Unfortunately, I cannot disable g-sync to test this, because the nvidia settings control panel doesn't work in wayland.

                    I'm not sure whoever implemented this behavior thought things through... :P
                    That reminds me of the AMD trick of setting /sys/class/drm/card0/device/power_dpm_force_performance_level​ to high. I had to do that nearly a decade ago with my R7 260x to fix stupid crap like stuttery mice and laggy animations during the earliest days of AMDGPU. I stilI have gamemode set that to high when gaming. Perhaps NVIDIA has some tweak like that you can do.

                    I'm trying to be helpful, but if you're on Gentoo you've probably already thought of something like that

                    Comment

                    Working...
                    X