Announcement

Collapse
No announcement yet.

KDE Plasma 6.1 Beta Released With Wayland Explicit Sync, Input Capture Portal & More

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • direc85
    replied
    I'm waiting for VRR fixes, I don't think my setup currently works properly in that regard... (It's also kind of a "can't be arsed to dig deeper" bug so meh.)

    FWIW, migration from Plasma 5 to 6 went fine for me! My daily driver ran Plasma 5 for a year or so when I updated it to Plasma 6 RC IIRC.

    According to Manjaro Linux forums, there has been a selection of small-ish issues, but luckily showstoppers have been rare.

    Leave a comment:


  • Vistaus
    replied
    Originally posted by Firnefex View Post


    It does not.
    ​​dataurl776285.jpg
    It shouldn't be that hard to implement. Deepin has this implemented (at least on V23) and that's based on Qt, too. And the corner rounding there works very well.

    Leave a comment:


  • Firnefex
    replied
    Originally posted by mrbumpy409 View Post

    In System Settings, go to Colors and Themes → Window Decorations, and change the border size from "Theme's default (No Window Borders)" to "Tiny Window Borders" or larger.​ You will now have rounded bottom corners as well. though the window border might not match content as perfectly this way depending on the window contents.
    It does not.
    ​​dataurl776285.jpg

    Leave a comment:


  • Firnefex
    replied
    Originally posted by skeevy420 View Post
    The 1 or 2 pixel gap between tiled, snapped, horizontal Qt toolkit based windows is annoying, too.
    Set shadows and borders to off.
    ​​​​​​dataurl839725.jpg
    Last edited by Firnefex; 25 May 2024, 11:27 AM.

    Leave a comment:


  • NSLW
    replied
    Plasma 6.0 is out already for a while, and Phoronix writes mainly about polishing, and not about severe bugs fixing. I guess the migration from Plasma 5.0 went smooth then

    Leave a comment:


  • WileEPyote
    replied
    Really like the new edit mode. Some of the changes to a couple of the settings pages are nice looking too.

    So far I haven't noticed any breaking bugs or behaviors. Hopefully it stays that way. lol

    Leave a comment:


  • mrbumpy409
    replied
    Originally posted by skeevy420 View Post
    They annoy me, too, but not because they're rounded. On Plasma 6.0 only the tops of my windows are rounded. The bottoms are square. That inconsistency is annoying. The usual saying is pick one, not both.
    In System Settings, go to Colors and Themes → Window Decorations, and change the border size from "Theme's default (No Window Borders)" to "Tiny Window Borders" or larger.​ You will now have rounded bottom corners as well. though the window border might not match content as perfectly this way depending on the window contents.

    Leave a comment:


  • ol3geezer
    replied
    Looking forward to being able to use this on KDE Neon. Ever since Action Retro made a video on it slaying an old iMac, I've been in love with it.

    Leave a comment:


  • bearoso
    replied
    Originally posted by EphemeralEft View Post

    I hope there's an option to undo that
    It's a consistency thing. I don't think it's that noticeable. Some corners may actually end up with a smaller radius. As it's theme-specific, and KDE supports user themes, you're free to install a different one or even clone it and tweak the values to make "Breeze-Squared."

    Leave a comment:


  • skeevy420
    replied
    Originally posted by EphemeralEft View Post

    I hope there's an option to undo that
    They annoy me, too, but not because they're rounded. On Plasma 6.0 only the tops of my windows are rounded. The bottoms are square. That inconsistency is annoying. The usual saying is pick one, not both.



    The 1 or 2 pixel gap between tiled, snapped, horizontal Qt toolkit based windows is annoying, too. Drag a couple of windows to the left and right sides of the screen to get them side by side and Qt based windows leave a gap on the vertical axis dead center of the screen. It's not there if both windows are GTK. Just something I happened to notice on a fresh install today.

    Leave a comment:

Working...
X