No announcement yet.

Help a noob: some wired network connection troubles on Ubuntu Studio 8.04

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help a noob: some wired network connection troubles on Ubuntu Studio 8.04

    I'm not even sure where I can ask for some advice as a noob, but here goes anyway.

    I'm still running Ubuntu Studio 8.04 and I've a wired net connection through ADSL that works automagically by DHCP. Internet browsing, online radios, everything seemed to be fine.

    Except games cannot connect to the internet. First I bought World of Goo (Linux native binaries) and it says it cannot connect in that goo-tower-building special level, where it would connect to compare heights to other people's. There's no system error, just a friendly in-game connection failure. I just thought their servers are down since my browsing is fine.

    And now, after getting the beta key for Heroes of Newerth, the same. When I run it, it somehow finds that the newest game version is newer than the installed one, but it just skips doing the update. So some part of the connecting works, some doesn't. And then, I search games to join, and it finds that there's e.g. 90 existing games, but then it cannot download the actual list of games so it appears as if there's none and there's nothing I can do.

    I thought to myself, this looks like some strong firewall rules or something? I searched how to configure Ubuntu 8.04's firewall and I found some ufw hints. I run ufw status and it says it's disabled.

    So if there's no firewall, what can block the games from connecting? (Heroes of Newerth manages to do some sort of connection though as I said but not enough)

    Thanks for whoever has the time to read this long post.
    Last edited by geamandura; 03 October 2009, 02:49 PM.

  • #2
    Originally posted by geamandura View Post
    I'm not even sure where I can ask for some advice as a noob, but here goes anyway. is the place to go to for ubuntu related help and in my opinion is the only thing that makes Ubuntu more feasible than other distros, specially if you are a newbie.
    There is also the channel #ubuntu on irc on (server) but I guess you will not be able to connect to it... but you can try install the XChat-GNOME IRC Chat (click the name to install)

    Any way. The problem is very strange.
    Before posting on ubuntuforums try manually set your ip and check our router. With default configs there should be nothing in your way of connecting to servers.

    Lets do it the GUI (graphical user interface) way as you might be more comfortable with that.
    Right click on the network icon and click Edit Connections
    Press + Add
    IPv4 Settings → Method: Manual
    Press + Add and Click the text box beneath Address and have the first 2 numbers in the IP same as you will find when you right click on the network icon and select connection information. Which is the same place as you will copy netmask ( and gateway (ip of your router on the internet) from.

    hope this will help but if it doesnt post on the ubuntuforums
    btw there is something called UGN (ubuntu gaming night) which you can google or look for on the game section on the ubuntu forums just letting you know.


    • #3
      Ubuntu also might have firewall enabled by default in a pretty restrictive mode. I don't remember if it does. Probably want to check iptables.


      • #4
        9 times out of 10 the dsl modem is a hybrid modem / router / firewall and many linux apps don't play well with UPnP (what really does).


        • #5
          Alternatively (and Im sure this is the initial response you will get in the Ubuntu forums), do a distro upgrade to 9.04. The 8.04 release is significantly old and an upgrade will probably fix your issue just by freshing your configs, unless you have a hardware issue.


          • #6
            I solved it!

            Thanks everyone for giving a hand, especially B?lvadur for your detailed attempt (I wrote on Ubuntu forums and got no reply but whatever)...

            None of the above guesses was the cause. It was something else... I don't even remember how I came to realize it but I'm glad I did (I was very very lucky considering my n00bness).

            OK so this was the problem: when installing the games, they were created with root ownership. I had to "chown myuser.myuser gamedir -R" and now they connect to the mighty internets Now, to finally start testing Heroes of Newerth, yummy.

            B?lvadur, I'll look into the gaming event, but time is tight atm so maybe I won't make it.
            Last edited by geamandura; 03 October 2009, 02:48 PM.