Announcement

Collapse
No announcement yet.

Firefox 94 To Start Using EGL On Linux - Better Performance, Lower Power Use

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Firefox 94 To Start Using EGL On Linux - Better Performance, Lower Power Use

    Phoronix: Firefox 94 To Start Using EGL On Linux - Better Performance, Lower Power Use

    Mozilla Firefox 94 will begin using its EGL back-end on the Linux desktop in conjunction with supported graphics drivers in order to provide better performance, lower power usage, and other benefits...

    https://www.phoronix.com/scan.php?pa...GL-Linux-Usage

  • #2
    Cool, but I wonder if this can bring any improvement for someone who already enabled WebRender and video hardware acceleration and it's already running well on Wayland.
    One thing that I hate is that Mozilla continues to ignore the other major desktop environment (KDE Plasma) and don't want to fix very annoying bugs like:
    https://bugzilla.mozilla.org/show_bug.cgi?id=1516290
    Last edited by Danny3; 30 October 2021, 07:19 AM.

    Comment


    • #3
      That's really good news. I can only speak for GNOME and not the KDE issues above, but I have both firefox (Stable, 93.0) and firefox-trunk (Nightly, 95.0-alpha) installed, and I've been using Nightly exclusively for the reasons Michael mentioned.

      Firefox is so much faster now in 95.0. It loads faster than Chrome for me

      95.0 adds the following features in about:support

      WEBGPU
      disabled by default: Disabled by default
      available by user: Enabled via dom.webgpu.enabled

      X11_EGL
      available by default

      DMABUF
      available by default

      I also do the following:

      WEBRENDER_SHADER_CACHE
      disabled by default: Disabled by default
      available by user: Enabled via gfx.webrender.program-binary-disk


      layout.frame_rate = 144 (since I have 144hz monitors)

      ---

      Here's what Firefox 93.0 looks like in about:support right now for me:

      WEBBGPU
      disabled by default: Disabled by default
      available by user: Enabled via dom.webgpu.enabled
      blocked by runtime: WebGPU can only be enabled in nightly
      X11_EGL
      available by default
      blocklisted by env: Blocklisted by gfxInfo
      DMABUF
      available by default
      unavailable by runtime: Requires EGL

      Comment


      • #4
        Here's a gif comparing the startups of Firefox 93 vs Firefox 95 vs Chrome 95.0. Chrome is still king, but Firefox is creeping up on that title quick.

        Comment


        • #5
          Originally posted by perpetually high View Post

          layout.frame_rate = 144 (since I have 144hz monitors)
          That explains the forums as of late.

          If I suddenly stop making posts y'all need to check perpetually high's basement since I'll likely be kicking it with 144hz.

          That really tempts me to go Nightly on Linux for the time being.

          Comment


          • #6
            Originally posted by skeevy420 View Post

            That explains the forums as of late.

            If I suddenly stop making posts y'all need to check perpetually high's basement since I'll likely be kicking it with 144hz.

            That really tempts me to go Nightly on Linux for the time being.
            Haha. And on that note - I noticed a few minutes ago when I was mirroring my screens that it defaulted to 120Hz when using the GUI in Display Settings.

            Previously on my old installation I was using an alias to mirror and join the two screens:

            alias mirror='xrandr --output DisplayPort-1 --mode 1920x1080 --rate 144.00 --output DisplayPort-0 --mode 1920x1080 --rate 144.00 --same-as DisplayPort-1'
            alias joined='xrandr --output DisplayPort-1 --mode 1920x1080 --rate 144.00 --pos 1920x0 --output DisplayPort-0 --mode 1920x1080 --rate 144.00 --pos 0x0'

            Now I'm back at 144hz and everything is way more crisp. This is why I do everything on the command line. Nothing beats it.

            Comment


            • #7
              This is one step forward towards hardware video acceleration being enabled by default. Right now you need both launching FF with MOZ_X11_EGL=1 and activate VA-API on the about:config tab. With 94 only the VA-API step will be necessary.

              Comment


              • #8
                Originally posted by Danny3 View Post
                One thing that I hate is that Mozilla continues to ignore the other major desktop environment (KDE Plasma) and don't want to fix very annoying bugs like:
                https://bugzilla.mozilla.org/show_bug.cgi?id=1516290
                Maybe someone from other major DE should step up and start fixing those bugs, because that's how gnome bugs get fix

                Comment


                • #9
                  maybe then I'll be able to run firefox with dedicated graphics without problems on wayland. I still can't using a laptop with nvidia, ubuntu , x and gnome.
                  when I right click firefox and run with dedicated graphics, it shows many gpu errors on about:support and does not have hardware acceleration enabled. I'm think I saw a bug on bugzilla about this but it was still opened. and when I run firefox with intel graphics it's got hardware acceleration and webrender is active.

                  Comment


                  • #10
                    Originally posted by perpetually high View Post
                    Here's a gif comparing the startups of Firefox 93 vs Firefox 95 vs Chrome 95.0. Chrome is still king, but Firefox is creeping up on that title quick.
                    They don't look like cold starts. You should also note if you're using an hdd/ssd/nvme as that (the disk I/O) is the most important thing for cold starts.

                    Comment

                    Working...
                    X