No announcement yet.

KDE vs Gnome - KDE frequent freezes when doing filesystem ops

  • Filter
  • Time
  • Show
Clear All
new posts

  • KDE vs Gnome - KDE frequent freezes when doing filesystem ops

    So I last used gnome as a daily driver around 7 years ago. Then I switch to KDE and loved it. Recently I tried manjaro gnome and then installed it alongside my Arco KDE install. Over time with fast hardware everything has got really fast and responsive and I have noticed an annoying part that only seems to apply to KDE. It appears as if filesystem operations run in the same thread or cause the main thread to wait unnecessarily long.

    If I have an sshfs (via autofs) mount open to another pc sometimes KDE will "freeze" - no screenupdates, kb does nothing (music etc will still play and you can ssh on etc). So even though the pc isn't using loads of resources it appears the threads hang the UI. Sometimes these lockups can last minutes. It's as if the UI is waiting for a "postevent" or processing of messages before doing anything.

    If I log out and use gnome, wow so super smooth - not necessarily faster in general it just feels SOOO fluid compared - KDE is more...erratic. I can download via ssh, send etc and Nauitlus has no issues with lag at all doing the exact same things.

    Apart from Gnomes better multitasking workflow and fluid response I prefer everything else about KDE.

    Any ideas as to what I can try? I have tried installing different kernels to no effect. (xanmod, zen, clear, amd). I have tried fresh installs - same. I even tried copying 100GB from one nvme to another and noticeable less than instant lag on KDE. Gnome - perfect, Windows....perfect ;(.

    Hardware is AMD 3900 and dual nvme's with additional 2 SSD's and 32GB 3200 ram. No swap.

  • #2
    You should probably use set a swap file in there and play around with the swappiness value. If you are constantly doing large disk operations you "need" swap even with plenty of RAM, otherwise you may run into problems. You can also try changing the default values for disk caching. This helped me a lot when I was also dealing with an unresponsive and sluggish desktop during large I/O operations. I'm also on KDE with various SSDs and 32GB of RAM and it was ridiculous that my desktop turned into a choppy mess when doing large file transfers (like during scheduled system backups).

    Could be worth it to check that out. Below are the values I use:

    #for system responsiveness
    vm.swappiness=10                                #default 60
    vm.dirty_background_ratio=5                     #default 10
    vm.dirty_ratio=40                               #default 20
    I just appended those at the end of my /etc/sysctl.conf and reboot.

    Just a bit of a disclaimer. Those values above will increase the I/O cache quite a bit, so be mindful of sudden power losses when doing file operations (I have a rather beefy UPS so no worries for me). The links provided detail what the settings do so you may want to experiment a bit to find something that works better for you.
    Last edited by Melcar; 19 September 2021, 12:47 PM.


    • #3
      Thanks for the reply Melcar, I'll give it a go.

      In saying that though when I do SSH ops, these aren't excactly "heavy io" it's like uploading a 100MiB file etc. So it doesn't appear to be a storage issue / cache issue. It's that Dolphin "hangs" and in turn causes KDE to hang. Also logging out and back in to gnome shows no such symptoms. My avg ram consumption sits around 800MiB - 1.2GiB in use with couple gigs cache.

      I have a 3kw UPS with 2x200ah lithium batteries so I'm good for power loss .

      --UPDATE - I've made the changes and will revert back
      Last edited by dfyt; 20 September 2021, 07:16 AM.


      • #4
        So just an update - the problem is still there but I found out what was causing the hang. Strawberry had a playlist open to my ssh'd pc and would hang. This STILL causes a hang on KDE...but closing the playlist in the meantime means no more hanging. Clearly though it's a bug in KDE. A couple years ago I recall reading about this filesystem threaded bug but can't seem to find it anymore. Either way it doesn't happen on gnome. Thanks for the suggestions anyways.