No announcement yet.

PipeWire Is In Increasingly Great Shape - Ready For More User Testing

  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Thanks Nocifer and pal666 for your answers.
    I don't have the low-latency use and I couldn't care less about flatpaks.
    If it's going to help with wayland's shortcomings, it's probably a good thing... I'll use both in 2-5 years when they're mature then.
    I just hope Pipewire won't break what PA has been striving for in the last 10+ years. My main desktop is a HTPC and I have a good setup for audio/video. Wouldn't want to regress to a less confortable state.
    If, on the other hand, it makes things even better/easier and I'm somehow excited by some capabilities I could take advantage of, I will of course gladly embrace it.


    • #42
      Here's how to get it installed on Ubuntu 20.04

      sudo apt install git build-essential meson cmake libsystemd-dev valgrind libdbus-1-dev libsdl2-dev libsndfile1-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libbluetooth-dev libsbc-dev libjack-jackd2-dev libvulkan-dev xmltoman
      git clone
      cd pipewire
      ./autogen --prefix=/usr
      make install
      launch an app like mpv with

      pw-jack mpv
      pw-pulse mpv

      To install wireplumber

      sudo apt install git gobject-introspection libxml2-dev libglib2.0-dev libjson-glib-dev libgirepository1.0-dev
      git clone
      cd wireplumber
      meson build . --prefix=/usr
      ninja -C build install
      For some reason the shared library isn't being created.

      Checking if "audiofade" with dependency libpipewire-0.3 compiles: NO (cached)
      Last edited by lyamc; 05 September 2020, 03:12 PM.


      • #43
        Originally posted by finalzone View Post

        Without pulseaudio doing the heavy lifting, ALSA would be in a terrible mess circa 2000 and none of users would access functions like Bluetooth support, audio USB and more in a modern environment. Too bad you missed a lot as pulseaudio drastically improved since then.
        Pipewire got a solid start now that pulseaudio served its purpose exposing and fix ALSA drivers bugs which were overdue.
        I think you're right and Pulseaudio has improved. But honestly i.e. the BT support just sucks and anyone who tried to fix it just was thanked by giant headaches and throwing the code back to the garbage.


        • #44
          Originally posted by thxcv View Post

          I think you're right and Pulseaudio has improved. But honestly i.e. the BT support just sucks and anyone who tried to fix it just was thanked by giant headaches and throwing the code back to the garbage.
          Well, I'm kind of impressed that my bluetooth headset works without any issue out of the box, and I can stream audio from my android phone the same way. Couldn't get any of them in windows 10 (at least without installing anything - work laptop). To me, it's not that broken.


          • #45
            Hey? Guess who just packaged libpipewire and its associated modules, and the pulse and jack libraries, for Arch multilib? Meeeeee, that's who! Packaged in the AUR for now, since several of the dependencies are in the AUR as well.


            Verified working with a Wine 32 bit application, specifically, foobar2000. I almost flubbed it up a bit first, missing packaging the libpipewire-module-*.so and spa-0.2 directories in the main pipewire package, which resulted in some spectacular crashes the instant I attempted to use audio output.


            • #46
              Originally posted by pkunk View Post

              Something like:
              • systemctl --global mask pulseaudio.service
              • pacman -S pipewire-pulse
              • create /etc/ with /usr/lib/pipewire-0.3/pulse
              • add NoExtract = usr/lib/libpulse* to pacman.conf
              • pacman -S libpulse
              • reboot

              Don't use wireplumber it currently doesn't work with the latest pipepewire.
              Multilib and flatpaks will not support this setup.
              It would be surprising if Bluetooth works.
              I can't really recommend the and delete libpulse method over tricking ldconfig with .0.999.0 symlinks, as the latter will still allow you to build and link libpulse-based applications on the system. Deleting the libpulse libraries from their normal location will break things, including linking copies of pipewire and the AUR lib32-pipewire package.


              • #47
                I will have to do some more investigation. I am on tumbleweed and it seems pipe wire is already installed.

                Man pipewire gives me this:

                pipewire(1) General Commands Manual pipewire(1)
                pipewire - The PipeWire media server
                pipewire [options]
                PipeWire is a service that facilitates sharing of multimedia content between devices and applications.
                The pipewire daemon reads a config file that is further documented in pipewire.conf(5)
                -h | --help
                Show help.
                Show version information.
                -n | --name=NAME
                Set the daemon name (Default pipewire-0).
                The PipeWire Developers <>; PipeWire is available from
                SEE ALSO
                pw-mon(1), pw-cat(1), pw-cli(1),