Announcement

Collapse
No announcement yet.

KDE Seeing Fresh Improvements For HiDPI Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Clevo 17" 4K with Plasma 5.19 and I find that 200% and 300% percent will avoid those nasty horizontal lines in Konsole but my preferred 250% (or anything else) has those damn horizontal lines. 200% is effectively 1920x1080 and 300% is 1280x720 (from a web browsers pov) so seeing as I now need glasses I am trailing 300% and finding it quite comfortable. Back to the '90s If my 4K TV worked then I'd be very happy with 200% but my HDMI output only works with Nvidia and that then introduces a whole other mess of HiDPI artifacts.

    If I knew work on fine-tuning HiDPI was held up until someone got the right hardware then I would have been happy to donate funds.

    Comment


    • #22
      Originally posted by ngraham View Post

      What's obvious to you may not be obvious to others. It's obvious to you because you're you!
      Well, I do write bug reports, no worries, but usually for the things that really bother me.

      Comment


      • #23
        Originally posted by aufkrawall View Post
        It indeed does, but look how bad fractional scaling is on Windows 10. I couldn't stand it with 27" @4k vs. 1440p.
        I don't know what you mean. Personally I recently had to start using Windows 10 on a hi definition laptop after many years of exclusive Linux usage (mainly Ubuntu Unity and KDE) and I was surprised how well the UI scaling works - in addition to butter smooth performance @ 60 fps and super fast response to my inputs. Sadly that shows to me how behind the whole stack is in Linux.

        Comment


        • #24
          Did anybody try some games when scaling is enabled? I tried that on Plasma Wayland and games are somehow scaled up too and the mouse input is completely off. Well, I will disable scaling again and return to my workaround of just increasing the DPI until this is solved.

          Comment


          • #25
            Originally posted by R41N3R View Post
            Did anybody try some games when scaling is enabled? I tried that on Plasma Wayland and games are somehow scaled up too and the mouse input is completely off. Well, I will disable scaling again and return to my workaround of just increasing the DPI until this is solved.
            Probably a wayland issue, Works fine for me with xorg

            Comment

            Working...
            X