Announcement

Collapse
No announcement yet.

GTK 3.98.2 Released As Another Step Towards GTK4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Originally posted by dragon321 View Post

    Well, historically we had GTK+2 without issues you described.
    I was around in the bad old days before QGtkStyle for using GTK+ themes in Qt and the GTK-Qt theme for using Qt themes in GTK. (Or, to be fair, before they were sufficiently bug-free to actually be usable. GTK-Qt has been around in unusable form for a long time.)

    Qt 3.x and GTK+ definitely did have that problem... it was just less likely because the theming API had been stable for long enough that there was a high probability you'd find something at least close to what you wanted for both toolkits.

    Comment


    • #42
      Originally posted by ssokolow View Post

      I was around in the bad old days before QGtkStyle for using GTK+ themes in Qt and the GTK-Qt theme for using Qt themes in GTK. (Or, to be fair, before they were sufficiently bug-free to actually be usable. GTK-Qt has been around in unusable form for a long time.)

      Qt 3.x and GTK+ definitely did have that problem... it was just less likely because the theming API had been stable for long enough that there was a high probability you'd find something at least close to what you wanted for both toolkits.
      To be honest I don't have problems integrating GTK and Qt these days. In the past there was some problems but now it's looking good. Qt GTK style still exists.

      Comment

      Working...
      X