Announcement

Collapse
No announcement yet.

KDE Saw More System Settings Work While EGLStreams KWin Support Stole The Show

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    I just wish KDE had the option to detect displays in its Display settings module. Having to use xrandr or reboot in 2019 is kind of archaic.

    Comment


    • #42
      Originally posted by Lanz View Post
      I just wish KDE had the option to detect displays in its Display settings module. Having to use xrandr or reboot in 2019 is kind of archaic.
      Umm. Isn't that already the case? I can just plugin a proyector, another panel, etc. to my laptop and all of those are being detected without a hussle.

      Comment


      • #43
        Originally posted by Lanz View Post
        I just wish KDE had the option to detect displays in its Display settings module.
        Working fine for me, so check your distro or upgrade from 4.0 to 5 already.

        Comment


        • #44
          Originally posted by Lanz View Post
          I just wish KDE had the option to detect displays in its Display settings module. Having to use xrandr or reboot in 2019 is kind of archaic.
          There is no button but I have no issues with actually detecting monitors in OpenSUSE Tumbleweed (KDE/Plasma 5)

          Comment


          • #45
            Originally posted by Mario Junior View Post
            KDE devs need fix Kwin perfomance on AMD graphics. I get a 570 and perfomance is disastrous with Plasma. Stutter, no 60fps all time, scroll with lag as hell on browsers...

            Same problem on Fedora with KDE, Solus, KDE Neon and Opensuse. With Gnome i don't have this problem.
            KWin in general has this stuttering problem because it syncs to a timer instead of VBlank. I attempted to solve that problem with a set of patches.

            Comment


            • #46
              Originally posted by starshipeleven View Post

              Wait, isn't the Vsync setting in KDE compositor settings enough? (I have it on "auto" btw)

              I thought the times I had to hack around in xorg config files were finally over something like 3 years ago
              On "auto", where it is now, without enabling VSync in xorg.conf I'll get tearing when scrolling anything (Firefox, Kate, terminals) and with videos (at least with mpv, mplayer, Netflix, and Hulu (both with Firefox); nothing else that I really notice. Enable it with the conf and it's fixed with "auto". Other KWin settings do fix it without the conf, but the compositor isn't as stable with them...to the point to where KWin will crash before Plasma has even fully started -- at least up to 5.14. Haven't tested on 5.15.

              I've had that experience with two different AMD cards with AMDGPU on KDE and XFCE, two TVs with the 260x and my current TV with the 580.

              Comment


              • #47
                Originally posted by skeevy420 View Post

                On "auto", where it is now, without enabling VSync in xorg.conf I'll get tearing when scrolling anything (Firefox, Kate, terminals) and with videos (at least with mpv, mplayer, Netflix, and Hulu (both with Firefox); nothing else that I really notice. Enable it with the conf and it's fixed with "auto". Other KWin settings do fix it without the conf, but the compositor isn't as stable with them...to the point to where KWin will crash before Plasma has even fully started -- at least up to 5.14. Haven't tested on 5.15.

                I've had that experience with two different AMD cards with AMDGPU on KDE and XFCE, two TVs with the 260x and my current TV with the 580.
                Hm, so the xorg.conf is for enabling vsync in the driver. If it is not enabled in the driver, that kwin setting does nothing.

                I guess in OpenSUSE this is set as a default somewhere else, as my xorg.conf.d config file for amdgpu is pretty generic.

                Comment


                • #48
                  Originally posted by tildearrow View Post
                  KWin in general has this stuttering problem because it syncs to a timer instead of VBlank. I attempted to solve that problem with a set of patches.
                  I just gave it a try: Wow, looks like you nailed it. Flawless compositing performance and I don't notice any increased hardware requirements.
                  Thanks a lot!

                  Comment


                  • #49
                    Originally posted by tildearrow View Post

                    KWin in general has this stuttering problem because it syncs to a timer instead of VBlank. I attempted to solve that problem with a set of patches.
                    So now I have to test your fork with and without Vsync and vanilla with and without those tweaks listed in the readme...bastard

                    (just in case the sarcasm button breaks, that's a thank you post and I'll give that a shot when I get off this evening)

                    Comment


                    • #50
                      Btw: There are pageflipping issues with AMD which might ruin your vsync on Xorg. You should have this PR for xf86-video-amdgpu:
                      https://gitlab.freedesktop.org/xorg/...ge_requests/33

                      And probably also this when using modesetting:
                      https://gitlab.freedesktop.org/xorg/...e_requests/131

                      Comment

                      Working...
                      X