Announcement

Collapse
No announcement yet.

Mozilla Preparing To Test WebRender With "Qualified" Linux Users

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by skeevy420 View Post

    Holding the scrollbar and moving my mouse up and down very fast makes it go up a massive 2%. [...]
    Added a third tab: went to Netflix and started watching Our Planet @ 1080p high quality. That caused [...] the CPU spiked to 5% usage for a split second when the video first loaded.
    You're 10 days late with that story. Good laugh, tho.

    Comment


    • #22
      Originally posted by skeevy420 View Post
      It's currently using .25% of my CPU and 286mb of ram with just the Manjaro homepage and this thread open. Holding the scrollbar and moving my mouse up and down very fast makes it go up a massive 2%. No screen tearing or any lag whatsoever.
      I don't know. For me, the main process idles at around 3%, with some extra going to the content processes. When moving my mouse cursor quickly over an about:blank page, the main process CPU goes to 15%. This is compared to 2% for a blank gedit document, and running on Gnome / Wayland.

      Comment


      • #23
        Originally posted by shmerl View Post
        Why no AMD? It works fine for me on radeonsi.
        I'm guessing it could have something to do with performance. I've done some tests of Chromium and Firefox on both my laptop with a iGPU and my desktop with a Radeon GPU. Webrenderer works fine on both in principle but when I do benchmarks on chromium and firefox on the laptop there's not that much of a difference. chromium is faster by a wide margin but not a gigantic one. On my desktop with Radeon the difference between Firefox and Chromium is gigantic as in mega huge and Firefox runs like it's stuck in glue, it's unbearably slow. I have no idea why this is the case. Webrender is faster than both stock and OpenGL on the desktop with a radeon, so it is the fastest option and they might as well enable it -- but there's something wrong or odd. If we call Chromium's performance 100% then Firefox runs at perhaps 80% on the Intel iGPU and Firefox Webrenderer on Radeon runs at perhaps 50%.

        It's kind of sad, I like Firefox, I love how it used to not have telemetry and used to respect users privacy and I liked how it used to be highly configurable and I enjoyed how it had a wide variety of plugins available.

        Comment


        • #24
          Originally posted by molecule-eye View Post

          It's usable depending on your hardware. E.g., if you don't care about auto rotation and even manual portrait rotation working, or don't care about clipboard history, or use only one monitor, or don't care about the touchscreen always working, then it should be fine. I love KDE but have a laptop with a touchscreen and an external display, so the wayland session wasn't usable for me.
          I have the right hardware: modern Intel hardware. But Plasma, even in its latest release, doesn't work fine for me on Wayland. The panel context menu still doesn't work and Dolphin still makes Plasma crash, just as in previous versions.

          Comment


          • #25
            Originally posted by tildearrow View Post
            Can you please tell me why 3440x1440? I don't see any valid reason, unless it is a lack of HiDPI support.

            (by the way, gfx.webrender.all is also effective and doesn't require an environment variable)
            4k is more gpu intensive, and webrender doesn't yet have all performance kinks ironed out. So for now, they are limiting it to lower resolutions where it performs well

            Comment


            • #26
              Originally posted by cl333r View Post

              NoScript is for masochists
              Not really, it just has a bit of a cold start. Once you have it remember most of the good sites you don't touch it again.

              Comment


              • #27
                Originally posted by tildearrow View Post
                Can you please tell me why 3440x1440? I don't see any valid reason, unless it is a lack of HiDPI support.
                That's the resolution of a 34" 21:9 display (e.g. Dell U3415W). I'm not sure it's directly a HiDPI thing, as there are 2560x1440 HiDPI (14") laptops.

                Comment


                • #28
                  Originally posted by gedgon View Post

                  You're 10 days late with that story. Good laugh, tho.
                  I listed an assload of disabled by default settings that activate GPU rendering, offscreen drawing, msaa, media playback, and more that I use and do have a noticeable effect on Firefox's performance. I can't tell you which ones are placebo and which ones actually do something which is why I listed them all.

                  I'd have to look up what setting depends on another setting, etc and try them individually and in different combinations to find where my performance gains come from. I'm too busy with other things away from my PC right now to actually do that.

                  Feel free to enable them and share your results. It's kind of an all or nothing approach, but I did paste what was in $HOME/.mozilla/firefox/gibberish.default/prefs.js so all you have to do is tack on what I posted to the bottom of that file (ensuring there aren't any duplicates/conflicts obviously) and revert it when you're done trying them.

                  And, for some reason with my RX 580, an xorg.conf that explicitly enables vsync works a little better on KDE than depending on KWin in regards to Firefox screen tearing (XFCE, I found out, requires the xorg.conf no matter what).

                  My lazy ass just did "man amdgpu" and made an xorg.conf with the default settings...and don't ask me why an xorg.conf with the default settings only works better than having no xorg.conf because I sure as shit can't figure that out...

                  Code:
                  Section "Device"
                       Identifier "AMD"
                       Driver "amdgpu"
                       Option "SWcursor" "off"
                       Option "Accel" "on"
                       #Option "ZaphodHeads" ""
                       Option "DRI" "3"
                       Option "EnablePageFlip" "on"
                       Option "TearFree" "on"
                       Option "VariableRefresh" "off"
                       Option "AccelMethod" "glamor"
                       Option "ShadowPrimary" "off"
                   EndSection

                  Comment


                  • #29
                    Originally posted by [email protected] View Post
                    Hmm, last time I tried it with that configuration (on sway/Wayland with GTK_PLATFORM), it just produced an empty window
                    looks like this is fixed in fx 67:

                    https://bugzilla.mozilla.org/show_bug.cgi?id=1514156

                    https://bugzilla.mozilla.org/show_bug.cgi?id=1532024

                    Comment


                    • #30
                      I tried enabling the webrender flags in about:config and then restarted, and about:support showed that compositing was set to webrender, but I noticed things definitely felt slower than when webrender was disabled, so I disabled it. This is on intel hardware (i5-7200U) on Manjaro Gnome. I can see why they don't enable it by default.

                      Comment

                      Working...
                      X