Announcement

Collapse
No announcement yet.

KDE Plasma 5.13 Is Making Great Improvements On Its Wayland Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • schmidtbag
    replied
    Originally posted by bitman View Post
    kaby lake cpu here, rx 580 + amdgpu. Will try OpenGL 2.0, thanks for the tip.

    By the way it is not unusably slow. It is perfectly usable. Thing is windows+compositing is exactly as fast as linux+no-compositing.
    It wouldn't surprise me if you're doing CPU rendering. I've found KDE+xrender compositing is modestly fast, even on slow single-core CPUs, but it is strictly CPU rendering. I don't know of a good way to prove if you're getting GPU-accelerated Wayland, but you may want to look into that too.

    Leave a comment:


  • bitman
    replied
    Originally posted by starshipeleven View Post
    Windows isn't using Wayland though.
    You think i do not know that? Point is that windows does compositing fast and linux (be it wayland or x11 or whatever) does not. Why not? This is not acceptable.

    Originally posted by schmidtbag View Post
    What hardware are you using and with what drivers? My Haswell-based laptop runs KDE+Wayland very smoothly.
    I've heard how setting the rendering backend to OpenGL 2.0 (instead of 3.1) can help improve performance.
    kaby lake cpu here, rx 580 + amdgpu. Will try OpenGL 2.0, thanks for the tip.

    By the way it is not unusably slow. It is perfectly usable. Thing is windows+compositing is exactly as fast as linux+no-compositing.

    Leave a comment:


  • dsreyes1014
    replied
    Originally posted by schmidtbag View Post
    I don't have my KDE setup in front of me, but from what I recall, you want to edit the "Session" variable in /etc/sddm.conf to use "plasmawayland.desktop". You may have to specify "SessionDir" to use wherever your Wayland sessions are stored (/usr/share/wayland-sessions seems to be the default for most distros). Definitely check that this directory exists first, because some distros have a separate package for it (like Arch).
    To my recollection, SDDM's login screen allows you to manually select if you want to run kwin_wayland, so it may be worth checking that out first, just to test if Wayland is working at all, or at least recognized by SDDM.

    So I can use a Wayland session and kwin_wayland is being used but I still cant close a window without it crashing on any of my PCs. Wonder if it's the window theme.

    EDIT: Turns out it's the breezemite theme that crashes.
    Last edited by dsreyes1014; 04-25-2018, 06:10 PM.

    Leave a comment:


  • schmidtbag
    replied
    Originally posted by dsreyes1014 View Post
    Which line do I tweak for Wayland sessions using SDDM? I'm also using SDDM and I have a fresh install.
    I don't have my KDE setup in front of me, but from what I recall, you want to edit the "Session" variable in /etc/sddm.conf to use "plasmawayland.desktop". You may have to specify "SessionDir" to use wherever your Wayland sessions are stored (/usr/share/wayland-sessions seems to be the default for most distros). Definitely check that this directory exists first, because some distros have a separate package for it (like Arch).
    To my recollection, SDDM's login screen allows you to manually select if you want to run kwin_wayland, so it may be worth checking that out first, just to test if Wayland is working at all, or at least recognized by SDDM.

    Leave a comment:


  • dsreyes1014
    replied
    Originally posted by schmidtbag View Post

    Hmm that's pretty weird. There are a lot of potential factors I can think of that may be causing this issue:
    1. Is Mesa working properly when you use Wayland? I wonder if everything is falling back to CPU rendering.
    2. Maybe your distro doesn't have Wayland properly configured? I personally am using Arch - it might help to reference Arch's wiki, regardless of what distro you use.
    3. Your display manager might be causing problems. I personally use SDDM, since you only have to tweak 1 line in the config file to start a Wayland session.
    4. To my knowledge, Wayland doesn't reference the xorg.conf, but I wonder if maybe having one conflicts with the way it behaves? From my recollection, my KDE setup still has an xorg.conf, but it might be worth deleting yours and see if that helps.
    5. Part of me wonders if maybe you have everything (including Plasma) running in Xwayland?
    6. Maybe you just need to do a fresh clean install. I didn't have to (I was already using my KDE setup for years before I switched to Wayland) but for such a complex system, you're bound to encounter something holding you back.
    Which line do I tweak for Wayland sessions using SDDM? I'm also using SDDM and I have a fresh install.

    Leave a comment:


  • gilboa
    replied
    Originally posted by theriddick View Post
    Had to stop using KDE because of how unfriendly kwin is to nvidia cards, had games unable to detect screen resolution, mouse not obeying designated screen in games, the list kept going on. It wasn't just related to multi-monitor configurations, I even had some games unable to detect 4k with just 1 screen enabled. Tragic!
    My experience is the exact opposite.
    Been using kwin + nVidia on Fedora and RedHat (RH9) since, err, 2000 (?).
    In the last couple of years, beyond a some issue with konsole, I can't remember any issues.
    I've got machines with 4K displays (w/ 1070 and 1080 GTX cards), dual head and even triple head (with older GPUs). Everything simply works.
    Steam / older games work out of the box.

    - Gilboa
    Last edited by gilboa; 04-25-2018, 05:54 AM.

    Leave a comment:


  • R41N3R
    replied
    I've tested some games like Tomb Raider and Rise of the Tomb Raider on Plasma-Wayland and the input got much worse, not sure if this is because of a recent Plasma 5.12.x update or maybe libinput 1.10.x. There always was the bug, that you have to press for 3 seconds the ESC key. But now it is nearly impossible to play, the mouse is inaccurate, you cannot move the view freely around in all directions and sometimes the view jumps 180 degree. Before I could play most of the games on Plasma-Wayland at least by pressing the ESC key for 3 seconds or going back to the desktop and then to the game again. So something regressed, did anybody else experience this? Hope that at least some input bugs will be addressed for Plasma-Wayland. Anyway, the desktop works great already on Plasma-Wayland and if there was a bug I could mostly work around them.

    Leave a comment:


  • Azrael5
    replied
    Originally posted by starshipeleven View Post
    this is nonsense, qtwayland is a library to build lightweight wayland compositors and to make applications that run as wayland clients, xwayland is a wrapper to run x11/xorg applications on wayland compositors.
    the sense is that xwayland is not necessary for qt.

    Leave a comment:


  • FireBurn
    replied
    Originally posted by cfeck View Post

    This myth was being discussed everywhere. What Martin said he won't add features to X11 unless the feature also works on Wayland. He did it for two reasons:
    - to have more time to close the feature-gap between X11 and Wayland
    - to not _enlarge_ this gap intentionally

    If you think about it, it makes 100% sense.
    He closed a bug of regarding modifiers, a new feature in Xorg-server 1.20, which will also be used in Wayland, because the Xorg side of Kwin is going to receive no more features

    Leave a comment:


  • schmidtbag
    replied
    Originally posted by Steffo View Post
    I can confirm these problems with Plasma 5.12.2 and my Intel Thinkpad T420. OpenGL setting is set to 2.0.
    I just upgraded my KDE Neon to Plasma 5.12.4 and Plasma Wayland did get smoother, but still X seems to be smoother when I click through all Plasma settings.
    Originally posted by dsreyes1014 View Post
    It is completely unusable on my haswell. Cant close any window in a wayland session without it crashing back to login screen.
    Hmm that's pretty weird. There are a lot of potential factors I can think of that may be causing this issue:
    1. Is Mesa working properly when you use Wayland? I wonder if everything is falling back to CPU rendering.
    2. Maybe your distro doesn't have Wayland properly configured? I personally am using Arch - it might help to reference Arch's wiki, regardless of what distro you use.
    3. Your display manager might be causing problems. I personally use SDDM, since you only have to tweak 1 line in the config file to start a Wayland session.
    4. To my knowledge, Wayland doesn't reference the xorg.conf, but I wonder if maybe having one conflicts with the way it behaves? From my recollection, my KDE setup still has an xorg.conf, but it might be worth deleting yours and see if that helps.
    5. Part of me wonders if maybe you have everything (including Plasma) running in Xwayland?
    6. Maybe you just need to do a fresh clean install. I didn't have to (I was already using my KDE setup for years before I switched to Wayland) but for such a complex system, you're bound to encounter something holding you back.

    Originally posted by miabrahams View Post
    NVidia isn't negligent - they looked at GBM, realized it would require forking their driver entirely for Windows vs. Linux, and that the business case was impossible to justify.
    That may have once been true, but I have a hard time believing things are still that way. Nvidia for the longest time has been the go-to for high-performance graphics in Linux. Nvidia didn't have to do anything the community wanted, because people bought their stuff anyway; there wasn't another option. It's natural for them to want to take the path of least resistance. But the thing is, to my knowledge, AMD's amdgpu-pro drivers managed to get EGL support, and those drivers share code with Windows. Seeing as AMD's proprietary devs are unimpressive (to say the least), I don't see why Nvidia couldn't do the same. Nvidia is notorious for not being compliant; they had years to make their drivers more than what feels like a last-minute port from Windows. Despite their reasoning, that sounds pretty negligent to me. Not only that, but they seem to intentionally put very little effort into Nouveau. But now, AMD is catching up faster than anyone expected; Nvidia has real competition now, so maybe they'll actually give a damn.

    Leave a comment:

Working...
X