Announcement

Collapse
No announcement yet.

system/gnupg-1.0.0 fails with gnupg version 2 and higher

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • system/gnupg-1.0.0 fails with gnupg version 2 and higher

    While running the system/collection suite. The system/gnupg test failed.
    gnupg version 2 and higher requires the use the the --batch paramater when using --passphrase-file.
    In system/gnupg-1.0.0 the following bash script is used

    gpg -c --no-options --passphrase-file passphrase -o /dev/null linux-4.3.tar 2> /dev/null

    This should be changed to

    gpg -c --no-options --batch --passphrase-file passphrase -o /dev/null linux-4.3.tar 2> /dev/null

    If the system version of gnupg is 2.x and higher.
    If the system version of gnupg is below 2.0 than the test script works fine.

    Noticed this on Gentoo.





  • #2
    Somehow missed out on this thread, but anyhow it's been fixed with latest system/gnupg-1.0.1. Thanks!

    http://openbenchmarking.org/test/system/gnupg
    Michael Larabel
    http://www.michaellarabel.com/

    Comment

    Working...
    X