Announcement

Collapse
No announcement yet.

No proxy but I still receive "[PROBLEM] Network support is needed to obtain..."

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No proxy but I still receive "[PROBLEM] Network support is needed to obtain..."

    I installed this yesterday on an internal network server using Ubuntu 17.04. I do not use a proxy as this is a small home network.

    Whenever I try to do anything it throws this error and takes a really long time to complete anything.

    [PROBLEM] Network support is needed to obtain...

    Any suggestions?

  • #2
    Is your network slow? PTS should run fine on Ubuntu 17.04, as I do a majority of my testing there and have yet to hit any network related problems... So you're on a traditional network with nothing 'special'?

    By chance if you install php-curl, does it change anything?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Gigabit internal network and a 75 Megabit Fiber connection to the internet.

      I installed php-curl prior to testing as it was one of the recommended packages.

      apt list --installed | grep php

      php-cli/zesty,zesty,now 1:7.0+49 all [installed,automatic]
      php-common/zesty,zesty,now 1:49 all [installed,automatic]
      php-curl/zesty,zesty,now 1:7.0+49 all [installed]
      php-fpdf/zesty,zesty,now 3:1.8.1.dfsg-2 all [installed]
      php-gd/zesty,zesty,now 1:7.0+49 all [installed]
      php-sqlite3/zesty,zesty,now 1:7.0+49 all [installed]
      php-xml/zesty,zesty,now 1:7.0+49 all [installed,automatic]
      php-zip/zesty,zesty,now 1:7.0+49 all [installed]
      php7.0-cli/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-common/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-curl/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-gd/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-json/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-opcache/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-readline/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-sqlite3/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-xml/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
      php7.0-zip/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]

      Comment


      • #4
        Originally posted by Arador View Post
        Gigabit internal network and a 75 Megabit Fiber connection to the internet.

        I installed php-curl prior to testing as it was one of the recommended packages.

        apt list --installed | grep php

        php-cli/zesty,zesty,now 1:7.0+49 all [installed,automatic]
        php-common/zesty,zesty,now 1:49 all [installed,automatic]
        php-curl/zesty,zesty,now 1:7.0+49 all [installed]
        php-fpdf/zesty,zesty,now 3:1.8.1.dfsg-2 all [installed]
        php-gd/zesty,zesty,now 1:7.0+49 all [installed]
        php-sqlite3/zesty,zesty,now 1:7.0+49 all [installed]
        php-xml/zesty,zesty,now 1:7.0+49 all [installed,automatic]
        php-zip/zesty,zesty,now 1:7.0+49 all [installed]
        php7.0-cli/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-common/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-curl/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-gd/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-json/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-opcache/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-readline/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-sqlite3/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-xml/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        php7.0-zip/zesty-updates,now 7.0.18-0ubuntu0.17.04.1 amd64 [installed,automatic]
        If you uninstall php-curl then, any difference?

        And/or what happens if you try from terminal:

        php -r "echo file_get_contents('http://phoronix-test-suite.com/PTS');"
        (It should print 'PTS' if it's working network wise, otherwise may see an error/warning giving an insight into PHP's problem.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Removing php-curl did the trick, thank you.

          Comment


          • #6
            Sorry, I spoke to soon. It is still showing the issue after php-curl was uninstalled.

            Comment


            • #7
              Both before and after php-curl was removed

              php -r "echo file_get_contents('http://phoronix-test-suite.com/PTS');"
              PTS

              Comment

              Working...
              X