Hi,
My first post here at Phoronix.
I did a JuliaGpu test and I got an error:
"The test quit with a non-zero exit status."

---------------------------------------------------------------------------------------------------
Phoronix Test Suite v7.0.1

Installed: pts/juliagpu-1.3.0


JuliaGPU 1.2pts1:
pts/juliagpu-1.3.0
System Test Configuration
1: CPU
2: GPU
3: CPU+GPU
4: Test All Options
OpenCL Device: 2


System Information


PROCESSOR: AMD Athlon 5150 APU with Radeon R3 @ 1.60GHz (4 Cores)
Core Count: 4
Extensions: SSE 4.2 + AVX
Cache Size: 2048 KB
Microcode: 0x700010b
Scaling Driver: acpi-cpufreq ondemand

GRAPHICS: ASUS AMD Radeon HD 8400 / R3
OpenGL: 4.3.13416
OpenCL: OpenCL 2.0 AMD-APP (1912.5)
Display Driver: fglrx 15.30.3
Monitor: SAMSUNG
Screen: 1600x900

MOTHERBOARD: ASUS AM1M-A
Memory: 4096MB
Chipset: AMD Family 16h Root Complex
Network: Realtek RTL8111/8168/8411

DISK: 250GB MAXTOR STM325031
File-System: ext4
Mount Options: data=ordered relatime rw
Disk Scheduler: DEADLINE

OPERATING SYSTEM: LinuxMint 17.3
Kernel: 3.19.0-32-generic (x86_64)
Desktop: Xfce 4.12
Display Server: X Server 1.17.1
Compiler: GCC 4.8.4 + Clang 3.4-1ubuntu3 + LLVM 3.4

Would you like to save these test results (Y/n): n


JuliaGPU 1.2pts1:
pts/juliagpu-1.3.0 [OpenCL Device: GPU]
Test 1 of 1
Estimated Trial Run Count: 3
Estimated Time To Completion: 11 Minutes [16:57 CEST]
Started Run 1 @ 16:47:13
The test quit with a non-zero exit status.
Started Run 2 @ 16:48:48
The test quit with a non-zero exit status.
Started Run 3 @ 16:50:24
The test quit with a non-zero exit status.
---------------------------------------------------------------------------------------------------

Next i did a debug-benchmark:

---------------------------------------------------------------------------------------------------
========================================
JuliaGPU (Run 1 of 1)
========================================


Test Run Command: cd /home/nunomiguel/.phoronix-test-suite/installed-tests/pts/juliagpu-1.3.0/ && ./juliagpu 0 1 preprocessed_rendering_kernel.cl 1920 1080 2>&1

/home/nunomiguel/.phoronix-test-suite/installed-tests/pts/juliagpu-1.3.0/juliagpu: line 3: 12870 Segmentation fault ./juliaGPU $@ > $LOG_FILE 2>&1

The test quit with a non-zero exit status.


Log File At: /home/nunomiguel/.phoronix-test-suite/installed-tests/pts/juliagpu-1.3.0/juliagpu-1.3.0-1495983215-1.log



The following tests failed to properly run:

- pts/juliagpu-1.3.0: OpenCL Device: GPU

---------------------------------------------------------------------------------------------------

Below is the log:

---------------------------------------------------------------------------------------------------

Usage: ./juliaGPU
Usage: ./juliaGPU <use CPU device (0 or 1)> <use GPU device (0 or 1)> <kernel file name> <window width> <window height>
OpenCL Platform 0: Advanced Micro Devices, Inc.
OpenCL Device 0: Type = TYPE_GPU
OpenCL Device 0: Name = Kalindi
OpenCL Device 0: Compute units = 2
OpenCL Device 0: Max. work group size = 256
Reading file 'preprocessed_rendering_kernel.cl' (size 8162 bytes)
OpenCL Device 0: kernel work group size = 256
Render 1 of 800: Rendering time 0.115 sec - Sample/sec 11473.2K
Render 2 of 800: Rendering time 0.104 sec - Sample/sec 12675.2K
Render 3 of 800: Rendering time 0.104 sec - Sample/sec 12631.6K
Render 4 of 800: Rendering time 0.104 sec - Sample/sec 12723.5K
Render 5 of 800: Rendering time 0.103 sec - Sample/sec 12737.9K
Render 6 of 800: Rendering time 0.105 sec - Sample/sec 12502.5K
Render 7 of 800: Rendering time 0.103 sec - Sample/sec 12848.3K
Render 8 of 800: Rendering time 0.105 sec - Sample/sec 12565.2K
Render 9 of 800: Rendering time 0.104 sec - Sample/sec 12713.4K
Render 10 of 800: Rendering time 0.104 sec - Sample/sec 12684.9K
...
Render 798 of 800: Rendering time 0.103 sec - Sample/sec 12761.2K
Render 799 of 800: Rendering time 0.104 sec - Sample/sec 12646.8K
Render 800 of 800: Rendering time 0.104 sec - Sample/sec 12684.6K

[FINAL] Elapsed Time: 83.797 sec - Sample/sec 12876862.9
---------------------------------------------------------------------------------------------------

What can be the problem?
Thank you all!