Announcement

Collapse
No announcement yet.

povray 1.1.2 installation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • povray 1.1.2 installation

    I'm new to the phoronix test suite. I'm using it under ubuntu 14.04: I've been trying to install the pts/cpu test and hitting problems when it tried to install pts/povray-1.1.2. After a lot of reading and trial-and-error, I seem to have found a workaround, and as I noticed that other people seemed to be having similar problems, I thought I'd say how I did it, in the hopes that it might be useful. (Not sure how this workaround will pan out into other ubuntu versions or other linux dists.)

    - I installed a number of boost libraries. The eventual command I used (after adding a number of prereqs which for some reason weren't automatically installed) was:

    apt-get install libboost-thread1.55-dev libboost-atomic1.55-dev libboost-chrono1.55-dev libboost-date-time1.55-dev libboost-system1.55-dev libboost1.55-dev libboost-serialization1.55-dev

    - I edited .phoronix-test-suite/test-profiles/pts/povray-1.1.2/install.sh - here's a diff between the original and the edited file:

    diff -u install.sh.original install.sh
    --- install.sh.original 2016-12-14 16:15:53.472406130 +0000
    +++ install.sh 2016-12-14 16:46:34.953321476 +0000
    @@ -5,8 +5,10 @@
    cd povray-3.7.0/

    cd unix/
    +autoupdate
    ./prebuild.sh
    cd ..
    +automake --add-missing
    LIBS="-lboost_system" ./configure COMPILED_BY="PhoronixTestSuite" --with-boost-thread=boost_thread
    make -j $NUM_CPU_JOBS
    echo $? > ~/install-exit-status

    - the other thing which I had to do was to remove .phoronix-test-suite/installed-tests/pts/povray-1.1.2/povray-3.7.0 (it seems as though this has to be done every time the install is re-run: this is something else which probably needs to be fixed in install.sh)

    After this, "phoronix-test-suite install pts/povray-1.1.2" completed successfully.








  • #2
    Originally posted by pwd4361 View Post
    I'm new to the phoronix test suite. I'm using it under ubuntu 14.04: I've been trying to install the pts/cpu test and hitting problems when it tried to install pts/povray-1.1.2. After a lot of reading and trial-and-error, I seem to have found a workaround, and as I noticed that other people seemed to be having similar problems, I thought I'd say how I did it, in the hopes that it might be useful. (Not sure how this workaround will pan out into other ubuntu versions or other linux dists.)

    - I installed a number of boost libraries. The eventual command I used (after adding a number of prereqs which for some reason weren't automatically installed) was:

    apt-get install libboost-thread1.55-dev libboost-atomic1.55-dev libboost-chrono1.55-dev libboost-date-time1.55-dev libboost-system1.55-dev libboost1.55-dev libboost-serialization1.55-dev

    - I edited .phoronix-test-suite/test-profiles/pts/povray-1.1.2/install.sh - here's a diff between the original and the edited file:

    diff -u install.sh.original install.sh
    --- install.sh.original 2016-12-14 16:15:53.472406130 +0000
    +++ install.sh 2016-12-14 16:46:34.953321476 +0000
    @@ -5,8 +5,10 @@
    cd povray-3.7.0/

    cd unix/
    +autoupdate
    ./prebuild.sh
    cd ..
    +automake --add-missing
    LIBS="-lboost_system" ./configure COMPILED_BY="PhoronixTestSuite" --with-boost-thread=boost_thread
    make -j $NUM_CPU_JOBS
    echo $? > ~/install-exit-status

    - the other thing which I had to do was to remove .phoronix-test-suite/installed-tests/pts/povray-1.1.2/povray-3.7.0 (it seems as though this has to be done every time the install is re-run: this is something else which probably needs to be fixed in install.sh)

    After this, "phoronix-test-suite install pts/povray-1.1.2" completed successfully.

    Thanks for the info, I haven't run povray in a while but will work on incorporating your changes into the test profile.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Hi Michael

      I should say that I'm not convinced that the libboost-*1.55* libraries are actually needed - at the time I installed them, I was just throwing everything I could find at the problem to try to fix it. At some point, I'll try removing packages gradually and see if I can isolate what's actually needed.

      ATB
      Peter

      Comment


      • #4
        The relevant changes were added to povray-1.1.3, but there appears to be issues building POVRAY with GCC6+ so I'm still running into issues on my end.

        http://openbenchmarking.org/test/pts/povray
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          It does seem to be a tricky build/install. I'll set up a vanilla ubuntu 14 VM and try building it on that - I'll record each dependency I need to satisfy before it works.

          Comment

          Working...
          X