Announcement

Collapse
No announcement yet.

PTS dependency and test downloading issues - OpenSuse Tumbleweed.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PTS dependency and test downloading issues - OpenSuse Tumbleweed.

    I tried running PTS on OpenSuse Tumbleweed, but it seems to not be recognizing installed packages. I try to run suite 52 (processor) and I get the following output:

    Code:
    The following dependencies are needed and will be installed:
    
    - java-1_6_0-openjdk
    - gtk2-devel
    - glibc-devel
    - glibc-devel-32bit
    - cairo-devel
    - bison
    - cmake
    - freeglut-devel
    - openmpi
    - portaudio-devel
    - go-doc
    - blas-devel
    - libatlas3-devel
    - lapack-devel
    - fftw3-devel
    - libbz2-devel
    - superlu
    - suitesparse-devel
    - tinyxml-devel
    - dune-common-devel
    - dune-istl-devel
    - perl-Digest-Perl-MD5
    - tcl
    - libqt4-devel
    - libgmp3
    
    This process may take several minutes.
    Please enter your root password below:
    Password:
    No provider of 'dune-common-devel' found.
    No provider of 'dune-istl-devel' found.
    No provider of 'java-1_6_0-openjdk' found.
    No provider of 'libatlas3-devel' found.
    No provider of 'libgmp3' found.
    Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata [....done]
    Building repository 'openSUSE-Tumbleweed-Non-Oss' cache [....done]
    Retrieving repository 'openSUSE-Tumbleweed-Oss' metadata [.......................................done]
    Building repository 'openSUSE-Tumbleweed-Oss' cache [....done]
    Loading repository data...
    Reading installed packages...
    'glibc-devel' is already installed.
    No update candidate for 'glibc-devel-2.24-2.2.x86_64'. The highest available version is already installed.
    'openmpi' is already installed.
    No update candidate for 'openmpi-1.10.3-2.2.x86_64'. The highest available version is already installed.
    'superlu' not found in package names. Trying capabilities.
    'glibc-devel-32bit' is already installed.
    No update candidate for 'glibc-devel-32bit-2.24-2.2.x86_64'. The highest available version is already installed.
    'dune-common-devel' not found in package names. Trying capabilities.
    'dune-istl-devel' not found in package names. Trying capabilities.
    'java-1_6_0-openjdk' not found in package names. Trying capabilities.
    'libatlas3-devel' not found in package names. Trying capabilities.
    'libgmp3' not found in package names. Trying capabilities.
    
    There are dependencies still missing from the system:
    - BZIP2 Development Libraries
    - Basic Linear Algebra Sub-Routine Library
    - Bison
    - CMake
    - Cairo Development Files and Libraries
    - Distributed and Unified Numerics Environment
    - Fast Fourier Transform 3 Library
    - GNU C Development Libraries w/ 32-bit Support
    - GTK Development Files
    - Go Language
    - Java Runtime Environment
    - Linear Algebra Pack
    - Linear Algebra Pack
    - OpenGL Utility Kit / GLUT
    - OpenMPI
    - Perl interface to the MD5 Algorithm
    - PortAudio Development Files
    - Qt4 Development Files
    - SuiteSparse
    - SuperLU
    - The GNU Multiple Precision Arithmetic Library
    - TinyXML Library
    - Tool Command Language
    
    1: Ignore missing dependencies and proceed with installation.
    2: Skip installing the tests with missing dependencies.
    3: Re-attempt to install the missing dependencies.
    4: Quit the current Phoronix Test Suite process.
    Missing dependencies action:

    Many of the packages it says are missing are installed, it just can't read them. Additionally, it says it needs to download 72 items to run the test, but it gets stuck on the third one (or somewhere in there). Any ideas?

  • #2
    Did I post this is the wrong subforum?

    Comment

    Working...
    X