Announcement

Collapse
No announcement yet.

Kernel tests from alternate kernel

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kernel tests from alternate kernel

    Is it possible to set Phoromatic up to perform the kernel tests on a kernel other than the mainline kernel? I'd like to be able to daily performance benchmarks on a kernel from a git repository and compare results as patches are added to the tree to track changes and if/how performance is affected.Bonus points if I can configure network bandwidth tests as part of it!

  • #2
    Originally posted by bigbadsubaru View Post
    Is it possible to set Phoromatic up to perform the kernel tests on a kernel other than the mainline kernel? I'd like to be able to daily performance benchmarks on a kernel from a git repository and compare results as patches are added to the tree to track changes and if/how performance is affected.Bonus points if I can configure network bandwidth tests as part of it!
    Yes, with the Phoromatic Server when creating a test schedule you can pass it any arbitrary script to run for setting up your environment, in this case the kernel, and then rebooting. It's designed to fit any one's needs, there is nothing at all in Phoromatic itself even about a 'kernel test schedule'

    The Phoronix Test Suite is extensible so new test profiles can be easily incorporated if you're able to script your own automated network bandwidth tests as part of a bash script, from there it's easy to take into PTS/Phoromatic.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      So I got it installed on two of my test systems... But for some reason, if I try to connect the local system to the Phoromatic server, it just hangs, when I type the "phoronix-test-suite phoromatic.connect x.x.x.x:yyyy/zzzzzz command, it returns the server IP, port, adn account ID, but then just sits there, and it never shows up under systems. When I try to connect my remote client, after entering the same command, it reboots, and again never shows up in the "systems" tab. Firewall is off on both systems and IP tables are flushed.

      Comment

      Working...
      X