No announcement yet.

Tests can't find pts-wav-sample-file.tar.bz2

  • Filter
  • Time
  • Show
Clear All
new posts

  • Tests can't find pts-wav-sample-file.tar.bz2

    At least the compress-pbzip2 test fails to find the wav/bz2 file in the pts-shared folder on installation.

    Some of the audio encoding suite tests may also have this problem, but I need to double-check this.

    I'm running the latest tarball from phorogit.

  • #2
    Were you using an already existing benchmarking environment? As in it was already installed? Try running phoronix-test-suite force-install audio-encoding. For those new users, this issue shouldn't be present.
    Michael Larabel


    • #3
      No, that was from a fresh installation.

      In order to get the pbzip2 test to run I needed to extract the tarball and then copy it to "bigfile" which is what the installation step seemed incapable of doing.

      Running the audio-encoding suite after that worked flawlessly, but I don't know whether that was because I'd already extracted the tarball, or because it doesn't have the same problem.

      I'm about to test another fresh installation starting with the audio-encoding suite to see if that will work.


      • #4
        Great, thanks, let me know how that new test goes. I experienced this issue once right after changing the scripts (previous to that there were ZERO problems), but I thought all regressions related to the new downloading were worked out.
        Michael Larabel


        • #5
          There are no problems with the audio-encoding suite, and I've worked out what the problem is with the pbzip2 test. In the install script, the cd .. that is on line 20, should actually be on line 14 thus:
          cd $1
          tar -xvf bzip2-1.0.5.tar.gz
          tar -xvf pbzip2-1.0.2.tar.gz
          cd bzip2-1.0.5/
          cp -f libbz2.a ../pbzip2-1.0.2
          cp -f bzlib.h ../pbzip2-1.0.2
          cd ..
          cd pbzip2-1.0.2/
          make pbzip2-static
          cd ..
          if [ ! -f ../pts-shared/pts-wav-sample-file.wav ]
               tar -jxvf ../pts-shared/pts-wav-sample-file.tar.bz2 -C ../pts-shared/
          rm -f bigfile
          for i in 1 2 3 4 5 6 7 8
              cat ../pts-shared/pts-wav-sample-file.wav >> bigfile
          cat > compress-pbzip2 <<EOT
          cd pbzip2-1.0.2/
          /usr/bin/time -f "PBZIP2 Compress Time: %e Seconds" ./pbzip2 -k -f -p\$NUM_CPU_CORES -r -5 ../bigfile 2>&1
          rm -f bigfile.bz2
          chmod +x compress-pbzip2
          Without the above modification the test will run correctly, but only if you have installed one of the other tests, like encode-mp3, which decompress the tar.bz2 file. The pbzip2 installation will give a set of tar errors, but continue anyway.

          If you install pbzip2 first, the test will fail.
          Last edited by uncle_fungus; 04-30-2008, 09:33 PM. Reason: Extra details


          • #6
            Oops, should be fixed in git. In all other scripts, that command is at the top of file, but for whatever reason I didn't do that in compress-pbzip2, but I have just moved it back up there. I was always running audio-encoding before compress-pbzip2 so it worked. Thanks for the report!
            Michael Larabel


            • #7
              No problem.