No announcement yet.

running phoronix-test-suite on Opensuse

  • Filter
  • Time
  • Show
Clear All
new posts

  • running phoronix-test-suite on Opensuse

    I have tested phoronix-test-suite on Opensuse 10.0 but the same should work for newer releases.

    before you start:
    - install php5,php5-gd,php5-posix
    make a link from php5 to php
    ln -s /usr/bin/php5 /usr/bin/php

    to avoid playing with searchpaths you may like to add

    ini_set("include_path", ini_get('include_path').".:../:./include:../include");

    as line just after <php? in pts-core/pts-run-cmd.php
    that will extend the current searchpath.

    Note: i am not a php programmer so there may be easier ways to do so

  • #2
    With the latest git today, it should no longer be needed to make the php5 to php link.
    Michael Larabel


    • #3
      Originally posted by Michael View Post
      With the latest git today, it should no longer be needed to make the php5 to php link.
      nice to read. did you also add the

      i had to add init_set() to all programs in pts-core
      will that be added to the next release also ?


      • #4
        Actually, I am trying to understand why you're having the include_path issue, as that shouldn't be a problem.
        Michael Larabel


        • #5
          i run into a problem i can not solve
          the script is looping:

          PHP Notice: Use of undefined constant STDIN - assumed 'STDIN' in /home/scratch/mnt/phoronix-test-suite/pts-core/functions/pts-functions.php on line 421
          PHP Warning: fgets(): supplied argument is not a valid stream resource in /home/scratch/mnt/phoronix-test-suite/pts-core/functions/pts-functions.php on li
          ne 421

          the problem is already descriped here:


          • #6
            Opensuse default include path is this:
            include_path = "/usr/share/php5"

            no dot, nothing else


            • #7
              more php errors

              it seems some more path are broken.
              i was able to download and compile some tests (until the rror above),
              I tried to continue by using the programms directly but
              it did not work,

              php pts-run-benchmark.php memory-bandwidth
              PHP Fatal error: Class 'tandem_XmlReader' not found in /home/scratch/mnt/phoronix-test-suite/pts-core/functions/pts-functions_config.php on line 19
              Content-type: text/html
              X-Powered-By: PHP/5.0.4