Announcement

Collapse
No announcement yet.

Nexuiz fails to launch on x64 systems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • deanjo
    started a topic Nexuiz fails to launch on x64 systems

    Nexuiz fails to launch on x64 systems

    Michael,

    You might want to take a look at this thread reguarding nexiuz and x64

    http://alientrap.org/forum/viewtopic.php?t=2776

  • deanjo
    replied
    Originally posted by Kano View Post
    (or did you install 32 bit libs for alsa?)
    Nope no 32-bit libs here.

    Leave a comment:


  • Kano
    replied
    Well usually in oss mode if you hear one (or did you install 32 bit libs for alsa?) - thats no good comparision. Also I found out that the Debian sid package of nexuiz was compiled with debug and that was much slower than the "official" one. Saidly this was compiled with a too new glibc 2.4 - other games like sauerbraten would work directly with the official packages. Therefore I disabled now the debug mode for the Kanotix repository - you can expect up to 40% speed improvement when you formerly used the sid package (or an unmodified backport).

    Leave a comment:


  • deanjo
    replied
    Originally posted by Kano View Post
    Well the nexuiz binary does not run with Debian etch, so I have to use a patch to use a locally installed backport. Also it seems to be wise to use -nosound option, because on 64bit sound does not work due to missing alsa in compatiblity libs.
    Did you apply the latest patch? Sound works fine here.

    Leave a comment:


  • Kano
    replied
    Well the nexuiz binary does not run with Debian etch, so I have to use a patch to use a locally installed backport. Also it seems to be wise to use -nosound option, because on 64bit sound does not work due to missing alsa in compatiblity libs.
    Last edited by Kano; 04-03-2008, 10:55 AM.

    Leave a comment:


  • deanjo
    replied
    Originally posted by Vadi View Post
    Same here, runs fine on my 64bit 7.10.

    I hope other distros fix that though.
    Try it on a non Debian based system. The patch should be made official soon for the game and integrated into a new build.

    Leave a comment:


  • Vadi
    replied
    Same here, runs fine on my 64bit 7.10.

    I hope other distros fix that though.

    Leave a comment:


  • deanjo
    replied
    Originally posted by Melcar View Post
    Nexuiz runs fine on my Gutsy x86_64 system
    That's because your probably running libtool 2.2 or libtool 1.5 with code patched.

    Leave a comment:


  • Melcar
    replied
    Nexuiz runs fine on my Gutsy x86_64 system

    Leave a comment:


  • deanjo
    replied
    pre Nexuiz patch

    http://global.phoronix-test-suite.co...190-9792-24916

    Post Nexuiz patch

    http://global.phoronix-test-suite.co...28-14647-16545

    Leave a comment:

Working...
X