No announcement yet.

test suite in arch chroot on android "No installation script found."

  • Filter
  • Time
  • Show
Clear All
new posts

  • test suite in arch chroot on android "No installation script found."

    So the phoronix test suite does not install tests in an archlinux chroot on android because of the error:
            Test Installation 1 of 11
                No installation script found.
    I haven't done really much in order to debug this, but I have looked in pts-core/objects/pts_test_profile.php and added in line 337
    echo ("Searching " . $test_resources_location . 'install' . $os_postfix . '.sh' . " or " . $test_resources_location . '');
    echo(is_file($test_resources_location . 'install' . $os_postfix . '.sh') || is_file($test_resources_location . '') ? "Yes":"No");
    and indeed it did output
    Searching /home/user/.phoronix-test-suite/test-profiles/pts/crafty-1.3.0/ or /home/user/.phoronix-test-suite/test-profiles/pts/crafty-1.3.0/install.shNo
    I also tried ctrl+z while it was running and searched for install*.sh but did not find anything in the phoronix test-profiles directory except some xml files.

    So I'm not sure how that test installation stuff works in the test suite and I have no idea what the problem could be. I have only further tested that php correctly identifies as "Linux" with php_uname('s').

    $ phoronix-test-suite detailed-system-info                    
    Phoronix Test Suite v4.6.0
    System Information
    Processor: ARMv7 rev 9 @ 0.70GHz (4 Cores), Motherboard: grouper, Memory: 1024MB, Disk: 16GB MAG2GA, Graphics: NVIDIA TEGRA
    OS: Arch Linux 2011.11-omap-smp, Kernel: 3.1.10-g6a965d1 (armv7l), Display Server: SurfaceFlinger, Compiler: GCC 4.7.2, File-System: ext4, Screen Resolution: 800x2560
    Core Count: 4
    Thread Count: 4
    Cache Size:  KB
    Instruction Set Extensions: 
    AES Encryption: NO
    Energy Performance Bias: NO
    Virtualization: NO
    Compiler Configuration: --build=armv7l-unknown-linux-gnueabihf --disable-build-poststage1-with-cxx --disable-build-with-cxx --disable-cloog-version-check --disable-libssp --disable-libstdcxx-pch --disable-libunwind-exceptions --disable-multilib --disable-ppl-version-check --enable-__cxa_atexit --enable-checking=release --enable-clocale=gnu --enable-cloog-backend=isl --enable-gnu-unique-object --enable-gold --enable-languages=c,c++,fortran,lto,objc,obj-c++ --enable-ld=default --enable-libstdcxx-time --enable-lto --enable-plugin --enable-shared --enable-threads=posix --host=armv7l-unknown-linux-gnueabihf --mandir=/usr/share/man --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16 --with-linker-hash-style=gnu --with-ppl
    Disk Mount Options: acl,errors=continue,relatime,rw,user_xattr
    Cpu Scaling Governor: tegra conservative
    xset:  unable to open display "localhost:10.0"
    Last edited by ChrisXY; 06-03-2013, 11:03 AM.

  • #2
    If you rm -rf ~/.phoronix-test-suite/test-profiles and rm -rf ~/.phoronix-test-suite/ and then re-run the process, does it work?
    Michael Larabel


    • #3
      Ah, my mistake. I just tried debug-install and it said
      NOTICE: The following PHP extensions are OPTIONAL but recommended:
      OpenSSL  PHP OpenSSL support is recommended to support HTTPS traffic.
      GD       The PHP GD library is recommended for improved graph rendering.
      POSIX    PHP POSIX support is highly recommended.
      PHP FPDF PHP FPDF is recommended if wishing to generate PDF reports.
      And then I enabled a bunch of extensions in php.ini that archlinux has disabled by default.

      And now it works.

      I'm not really sure which one it was. So it's really only a very minor bug/issue that it should be checking if all required php extensions are enabled and print an error if not.