Announcement

Collapse
No announcement yet.

Phorinix test suite installed But GUI does not run

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Phorinix test suite installed But GUI does not run

    Hi

    I installed the "phoronix-test-suite_2.4.1_all.deb"
    on my debian system but when i start phoronix-test-suite from
    icom no GUI is coming. means application does not run.
    Please help me out

    Thanks
    Ahmad

  • #2
    You need to install PHP5 GTK.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      i tried to install php5 gtk by using command
      apt-get install php5-gtk
      AND
      apt-get install php5-gtk2
      but not getting install,says that


      E: Couldn't find package php5-gtk
      E: Couldn't find package php-gtk
      E: Couldn't find package php5-gtk2

      plz help me

      Comment


      • #4
        Ubuntu/Debian doesn't offer any PHP5 GTK packages, you need to build it from source. Read the included documentation.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          please can u tell me the link
          how can test my system ?
          is thr any tutoril to do testing step by step

          Thanks

          Comment


          • #6
            Originally posted by ahmad92hassan View Post
            please can u tell me the link
            how can test my system ?
            is thr any tutoril to do testing step by step

            Thanks
            go to http://software.opensuse.org/search
            I had the same problem and iirc I saw a package for Ubuntu

            Comment


            • #7
              Phoronix gui not run in base Lucid

              Originally posted by clark_b View Post
              go to http://software.opensuse.org/search
              I had the same problem and iirc I saw a package for Ubuntu

              [email protected]:~/Download$ lsb_release -a
              No LSB modules are available.
              Distributor ID: Ubuntu
              Description: Ubuntu 10.04 LTS
              Release: 10.04
              Codename: lucid
              [email protected]:~/Download$ phoronix-test-suite gui-gtk
              PHP Warning: PHP Startup: php-gtk: Unable to initialize module
              Module compiled with module API=20060613
              PHP compiled with module API=20090626
              These options need to match
              in Unknown on line 0
              PHP Fatal error: Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 24
              [email protected]:~/Download$

              Package .deb incomplet for phoronix install in Ubuntu Lucid, whereis a solution fix for this,,,,?

              Comment


              • #8
                Hi everyone, I've managed to compile PHP-GTK manually on Ubuntu Lucid and I'll make a blog post about the process tomorrow (it's kind of late here). Stay tuned!

                Comment


                • #9
                  Well I've spent the afternoon figuring out how to compile PHP-GTK by myself and after I succeed I find threads with workable solutions. Hrmph.
                  SuporteTecnicoID, here you go: How to build PHP5-GTK2 on Ubuntu Lucid Lynx 10.04?

                  Comment

                  Working...
                  X