Announcement

Collapse
No announcement yet.

Easy PTS installation/access for the command-line shy?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Michael View Post
    Oh yeah, add extension=php_gtk2.so to your /etc/php5/cli/php.ini file. That's one thing the Deb didn't do.
    That worked, thanks!

    Comment


    • #12
      Originally posted by frustrated-one View Post
      I have no clue why I even bother to post this for a piece of software that is "nice to have" - but not essential by any stretch of the imagination - after having wasted so much time already. But here is my evening's fun with Phoronix....

      The system in question is an Intel Core Duo machine (not Core 2 Duo), so it does not have the x64 extensions:

      => Live CD is useless, as no i386 version is available

      So I downloaded the .deb package for Ubuntu and installed it on Ubuntu Jaunty i386 version. OK. Launcher is added to the Gnome menu, but does nothing. Most users just blacklist Phoronix in their minds at this point and uninstall the thing. I started from the command line with the gui option and got the complaint that PHP-GTK is missing. This lead me here.

      Thanks for the link to the x64 deb-file, I guess. No i386 binary, again.

      I went ahead to download the source for php-gtk, which just lead into dependency hell. I had to install about a dozen additional package by interpreting the crpytic messages from that packages configure script.

      At the end, all in vain. Obviously, the blooming php-gtk package does not currently compile on Debian derivates at all, you get a "LTOPTIONS_VERSION is m4_require'd but not m4_defun'd" message and some similar ones, followed by a SYNTAX ERROR in line 12673 message - and that's it. No make file.

      Can anyone point me to a i386 .deb for php-gtk - or is it time for me to blacklist Phoronix in my mind, too?

      BTW: why bother with an Ubuntu .deb for the Phoronix test suite at all, if the package cannot satisfy it's dependencies anyway?
      I tried compiling php-gtk as well at first and also ran into dependency hell, which was part of the reason I started this thread, not to mention any end "normal" computer users would be completely put off by that. Developers really need to compile their own code instead of leaving it up to non-developers. There's just a rift there that some devs don't understand and aren't sympathetic to.

      Anyhoo, the above steps worked for me, the two 64-bit packages installed correctly and after adding the line in the php config file just because it was surprisingly somehow left out (KIND of critical to initialize a newly installed php module, doncha think?), it worked.

      As for 32-bit, I'd blame an apparent lack of interest in packaging as well as the depreciation of 32-bit since of course most newer CPUs are 64/32, and thus a lack of interest in 32-bit. Several years ago it was hard to switch to 64 but now you can get most any package for 64.

      Either way, I will rant for a moment and note that it is a pity that:
      a) it's apparently so difficult to easily get a binary compiled for either arch
      b) easily compile a user-friendly package for any Linux distro, since a real package standard doesn't exist. Yes, regular file archives (tars) of straight binaries are great and all, but
      1) you confuse normal computer users once again since sometimes it isn't obvious which thing to run. On Windows, you look for the EXE file. Most every computer user has learned this by now, but on Linux there is no equivalent identifier, but *hopefully* there is a gear or some other icon, or a unique icon for the program, that looks obvious enough for them to find..
      2) won't be added to your installer/remover, won't add menu shortcuts for you, etc. More Linux installers are needed or a cross-distro package format is.

      Comment

      Working...
      X