Announcement

Collapse
No announcement yet.

running test suite on local network with no internet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • running test suite on local network with no internet

    Is there a configuration setting to disable requests to the Internet from the suite? My network that I want to run the suite on has no Internet connection.

  • #2
    Run: phoronix-test-suite user-config-set NoNetworkCommunication=TRUE to disable PTS from trying to use the Internet. Then with all of your files needed for the tests, drop that into ~/.phoronix-test-suite/download-cache/ or use a similar cache as is described in the documentation.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      2.8.1 NoNetworkCommunication is not honoured

      Hi,

      I'm running 2.8.1 and have NoNetworkCommunication set to TRUE, however it ignores this and attempts to download the tests.

      Code:
      <Networking>
           <NoNetworkCommunication>TRUE</NoNetworkCommunication>
           ...
      </Networking>

      I also have a download cache on a different host in our lab and have specified this in the CacheDirectory value:

      Code:
      <Installation>
      ...
           <CacheDirectory>http://x.x.x.x/phoronix/</CacheDirectory>
      </Installation>
      (i do actually specify a valid IP address)

      However it does not attempt to talk to my http server, and instead tries to contact the phoronix mirrors.

      Am I specifying this correctly? The documentation doesn't explictly say, however I suspect it's a bug.

      Comment


      • #4
        Hi Paul,

        The NoNetworkCommunication option is more primarily for communication with the Phoronix servers as if you don't have the test files stored locally in a download cache, you will need to use some form of network communication whether it be a download cache on the LAN or via the usual web-based downloads.

        At http://x.x.x.x/phoronix/ is it a copy of the download-cache directory? As in all of the files are in that folder, including the XML file it generates with the make-download-cache command? When doing HTTP/FTP/anything-remote communication, it checks for the XML file as from there it reads a list of the available files that should be available along with their reported hash sums rather than checking for files directly and seeing if it times-out.

        Is this PTS 2.8.x that you are using?
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Hi Michael,

          Yes it's 2.8.1.

          Here's the directory listing you get from apache for that location:

          Code:
          Index of /phoronix/tests
          [ICO]	Name	Last modified	Size	Description
          [DIR]	Parent Directory	 	-
          [TXT]	aio-stress.c	24-Nov-2010 19:16 	39K
          [ ]	apache-ab-test-files-1.tar.gz	24-Nov-2010 19:16 	5.9K
          [ ]	byte-benchmark-1.tar.gz	24-Nov-2010 19:16 	179K
          [ ]	flac-1.2.1.tar.gz	24-Nov-2010 19:16 	1.9M
          [ ]	fs_mark-3.3.tar.gz	24-Nov-2010 19:16 	15K
          [ ]	httpd-2.2.11.tar.gz	24-Nov-2010 19:16 	6.5M
          [ ]	iozone3_347.tar	24-Nov-2010 19:16 	1.6M
          [ ]	lame-398-2.tar.gz	24-Nov-2010 19:16 	1.3M
          [ ]	linux-2.6.25.tar.bz2	24-Nov-2010 19:16 	46M
          [ ]	linux-2625-config.tar.gz	24-Nov-2010 19:16 	43K
          [TXT]	pts-download-cache.xml	24-Nov-2010 19:16 	2.0K
          [ ]	pts-trondheim-wav-3.tar.gz	24-Nov-2010 19:16 	75M
          [ ]	pybench-2009-08-14.tar.gz	24-Nov-2010 19:16 	86K
          [ ]	ramspeed-2.6.0.tar.gz	24-Nov-2010 19:16 	76K
          [ ]	tscp181.zip	24-Nov-2010 19:16 	75K
          Apache/2.2.3 (Red Hat) Server at x.x.x.x Port 80
          As you can see the xml file is present, and it if you click on it it displays. I copied these directly off the download-cache directory on the test machine onto the remote machine, then deleted the files on the test machine.

          Are you able to clarify what exactly the NoNetworkCommunication flag does? It definitely seems logical that it still permits network communication if the download cache is specified as a remote http location, but surely it is not logical for it to ever attempt to talk to the web based phoronix mirrors when this is set, or else what is its function?

          Thanks!

          Paul

          Comment


          • #6
            The NoNetworkCommunication basically blocks the user from potentially uploading any results to Phoronix Global, not submitting any statistical data if you opt to do so when prompted, etc. Though in PTS3 this will be cleared up more and refined.

            I'll take a look into your network mirror issue and get back to you soon as I've seen if there's an issue in the network part of it (should know by Monday). I use download cache shares all the time on PTS 2.8/3.0 when using it off an external hard drive attached to the machine where it auto-detects it and works just fine locally, but there might be a bug then in the latest version [I rewrote the test installation code recently] if your network mirror isn't working as it does look like you have it setup correctly.

            -- Michael
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              In Phoronix Test Suite 3.0 Alpha 3 to be released in a few days (likely this week or early next week if I end up squeezing a few more things into it) contains a new code path being used in the download mechanism that should better support network mirrors, but let me know if it doesn't work out for you.
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #8
                Hello everyone! I am facing the same problem that Paul.

                I want to evaluate a PC without Internet access and run some tests downloaded in another PC where a HTTP server is up.
                So, in user-config.xml file I changed the Cache Directory (something like: http://IP_SERVER/remote_folder/) and set the NoInternetCommunication and NoNetworkCommunication flags in TRUE (or just the first one in TRUE or just the second one in TRUE or both of them in FALSE). Also I put the cache xml file in remote folder. However, the tests faile to install because can't be download the tests files.

                My phoronix-test-suite version is 7.6.0.

                Many thanks in advance!
                Fabián.

                Comment


                • #9
                  Originally posted by ffrommel View Post
                  Hello everyone! I am facing the same problem that Paul.

                  I want to evaluate a PC without Internet access and run some tests downloaded in another PC where a HTTP server is up.
                  So, in user-config.xml file I changed the Cache Directory (something like: http://IP_SERVER/remote_folder/) and set the NoInternetCommunication and NoNetworkCommunication flags in TRUE (or just the first one in TRUE or just the second one in TRUE or both of them in FALSE). Also I put the cache xml file in remote folder. However, the tests faile to install because can't be download the tests files.

                  My phoronix-test-suite version is 7.6.0.

                  Many thanks in advance!
                  Fabián.
                  Are you able to try 7.8 or 8.0 Git?

                  Otherwise you could try just using wget/curl to download all of those remote files into your ~/.phoronix-test-suite/download-cache/ to also get them picked up for sure.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #10
                    Thank you for the quick response.

                    In my first try I put the URL http://IP_SERVER/remote_folder/file1 in the download.xml file but it failed because apparently before use the URL checks if there is internet conectivity, although the host would be reached because is a local PC in a LAN.

                    Maybe I can leave download.xml empty and just use wget (actually an equivalent command because I am on Windows) in the install script.

                    Fabián.

                    Comment

                    Working...
                    X