Announcement

Collapse
No announcement yet.

Phoronix Test Suite 1.8 Released

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • another_sam
    replied
    Originally posted by Michael View Post
    Did you install php5-gtk?
    nop.

    should I download
    http://gtk.php.net/do_download.php?d...k-2.0.1.tar.gz
    compile and install?

    does it exist another dumber way to install php-gtk on ubuntu?

    thanks!

    edit: I tried but I can't

    http://forum.codecall.net/tutorials/...tml#post189668
    make: *** No targets specified and no makefile found. Stop.

    http://ubuntuforums.org/showthread.p...01#post7732301
    Fatal error, aborting.
    cvsread: no such user
    Last edited by another_sam; 04 August 2009, 12:32 PM.

    Leave a comment:


  • Michael
    replied
    Originally posted by another_sam View Post
    Got this for PTS 2.0.0 on Ubuntu 9.04 Desktop updated until today. Anyone with the same issue?

    I installed it clicking
    http://www.phoronix-test-suite.com/r..._2.0.0_all.deb
    and following the wizard. All the process went fine apparently.

    Thank you.
    Did you install php5-gtk?

    Leave a comment:


  • another_sam
    replied
    also in pts 2.0

    Fatal error: Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 23
    Got this for PTS 2.0.0 on Ubuntu 9.04 Desktop updated until today. Anyone with the same issue?

    I installed it clicking
    http://www.phoronix-test-suite.com/r..._2.0.0_all.deb
    and following the wizard. All the process went fine apparently.

    Thank you.

    Leave a comment:


  • sandalle
    replied
    Originally posted by WSmart View Post
    I get the same error in Ubuntu, 8.10, pre-release updates installed:

    desktop:~$ phoronix-test-suite gui

    Fatal error: Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 23

    I don't see a PHP-GTK, searching Synaptic. I do have all the recommended requirements installed, as listed with Synaptic.
    I also have this issue on Source Mage GNU/Linux with PHP-GTK 2.0.1. I know PHP-GTK has GtkWindow support:
    $ nm $(php-config --extension-dir)/php_gtk2.so |grep GtkWindow|wc -l
    125

    I even tried with php_gtk2.so (the only file php-gtk installs) in /usr/lib, with no success.

    This gets me further:
    Originally posted by Michael View Post
    Oops, forgot to make one minor note:

    In the /etc/php5/cli/conf.d folder (or something similar) create a gtk2.ini file and just do:

    extension=php_gtk2.so

    or just append that line to your php.ini file.
    but now I get:
    PHP Warning: PHP Startup: Unable to load dynamic library './php_gtk2.so' - ./php_gtk2.so: cannot open shared object file: No such file or directory in Unknown on line 0

    Fatal error: Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 23
    So PHP doesn't seem sure it's extension are where `php-config --extension-dir` says it is? Apparently not, by modifying my /etc/php.ini to have extension_dir set to the value returned by $(php-config --extension-dir) then `phoronix-test-suite gui` now loads.

    Looking at my /etc/php.ini (default install from PHP with the Phoronix upload requirements changed) I see:
    ; Directory in which the loadable extensions (modules) reside.
    extension_dir = "./"
    but this then breaks PHP (e.g. trying to recompile php-gtk gives this):
    checking for gawk... gawk
    checking for PHP-GTK support... yes, shared
    checking for PHP executable in /usr/bin... found version 5.2.9
    configure: error: PHP CLI version is required, found
    ! Problem Detected !
    If I set my extension_dir back to "./" my PHP apps can now find PHP CLI when compiling, but `phoronix-test-suite gui` can no longer find './php_gtk2.so'.
    Last edited by sandalle; 27 April 2009, 06:25 AM.

    Leave a comment:


  • Jimmy
    replied
    Originally posted by deanjo View Post
    Jimmy it is available for suse
    Mumble grumble grumble... I already looked there... or so I thought. Meh... wasn't the only thing I missed yesterday. Thanks deanjo.

    Leave a comment:


  • deanjo
    replied
    Originally posted by Jimmy View Post
    I give up. php-gtk isn't available from my distribution and the source for it won't build.

    Has anyone successfully got it working on OpenSuse 11?
    Jimmy it is available for suse (and yes it runs in suse fine). You need to add the PHP Extensions repository from the build service. (Add one of the following URL's into Yasts Repository.

    http://download.opensuse.org/reposit...openSUSE_11.0/ <---- for 11.0

    http://download.opensuse.org/reposit...openSUSE_11.1/ <---- for 11.1

    The package that you are looking for is called php5-gtk.........rpm

    Leave a comment:


  • Jimmy
    replied
    I give up. php-gtk isn't available from my distribution and the source for it won't build.

    Has anyone successfully got it working on OpenSuse 11?

    Leave a comment:


  • b15hop
    replied
    Originally posted by Michael View Post
    What is your echo $PATH output?

    Code:
     [email protected] $ echo $PATH
    /bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/opt/bin:/usr/local/bin:/opt/java/jre/bin:/opt/kde/bin:/opt/mozilla/bin:/usr/bin/perlbin/site:/usr/bin/perlbin/vendor:/usr/bin/perlbin/core:/opt/qt/bin:/opt/intel/cc/10.1.015/bin
     [email protected] $

    Leave a comment:


  • Michael
    replied
    What is your echo $PATH output?

    Leave a comment:


  • b15hop
    replied
    Originally posted by Michael View Post
    Do you not have curl or wget installed? If you do, where are they located?
    Code:
     [email protected] $ wget
    wget: missing URL
    Usage: wget [OPTION]... [URL]...
    
    Try `wget --help' for more options.
     [email protected] $ curl
    curl: try 'curl --help' or 'curl --manual' for more information
     [email protected] $ whereis wget
    wget: /usr/bin/wget /usr/share/man/man1/wget.1.gz
     [email protected] $ whereis curl
    curl: /usr/bin/curl /usr/include/curl /usr/share/man/man1/curl.1.gz
     [email protected] $

    Leave a comment:

Working...
X