Announcement

Collapse
No announcement yet.

Failed pts/server suite ; broken tests: mcperf-1.3.0 / memcached-1.6.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed pts/server suite ; broken tests: mcperf-1.3.0 / memcached-1.6.0

    exec: phoronix-test-suite debug-benchmark pts/mcperf
    Code:
    ========================================
    Memcached mcperf (Run 1 of 1)
    ========================================
    
    
    Test Run Command: cd /var/lib/phoronix-test-suite/installed-tests/pts/mcperf-1.3.0/ && ./mcperf --linger=0 --call-rate=0 --num-calls=1000000 --conn-rate=0 --sizes=d5120 --method=add --num-conns=1 2>&1
    
    Segmentation fault (core dumped)
    ./mcperf: 11: kill: Usage: kill [-s sigspec | -signum | -sigspec] [pid | job]... or
    kill -l [exitstatus]
    debug execute:
    Code:
    [email protected]:/var/lib/phoronix-test-suite/installed-tests/pts/mcperf-1.3.0# ./mcperf --linger=0 --call-rate=0 --num-calls=1000000 --conn-rate=0 --sizes=d5120 --method=add --num-conns=1 2>&1
    ./mcperf: 2: cd: can't cd to /root/memcached-1.6.0
    ./mcperf: 3: ./memcached: not found
    ./mcperf: 7: cd: can't cd to /root/mcperf-0.1.1
    ./mcperf: 8: cannot create : Directory nonexistent
    ./mcperf: 11: kill: Usage: kill [-s sigspec | -signum | -sigspec] [pid | job]... or
    kill -l [exitstatus]
    Script /var/lib/phoronix-test-suite/installed-tests/pts/mcperf-1.3.0/mcperf looks bit strange:
    Code:
    #!/bin/sh
    cd ~/memcached-1.6.0
    ./memcached -d -t $NUM_CPU_CORES
    MEMCACHED_PID=$!
    sleep 3
    
    cd ~/mcperf-0.1.1
    ./src/mcperf [email protected] > $LOG_FILE 2>&1
    echo $? > ~/test-exit-status
    
    kill -9 $MEMCACHED_PID
    sleep 3
    home directory looks wrong .. in /var/lib/phoronix-test-suite/installed-tests/pts/mcperf-1.3.0/memcached-1.6.0 is also no memcached binary .. but install/make log looks ok

    Info about the test system:
    Code:
    ========================================
    Phoronix Test Suite v10.0.1
    System Information
    ========================================
    
    
    PROCESSOR: AMD EPYC 7302P 16-Core @ 3.00GHz
    Core Count: 16
    Thread Count: 32
    Extensions: SSE 4.2 + AVX2 + AVX + RDRAND + FSGSBASE
    Cache Size: 128 MB
    Microcode: 0x8301034
    Core Family: Zen 2
    Scaling Driver: acpi-cpufreq ondemand
    
    GRAPHICS: ASPEED
    Screen: 1024x768
    
    MOTHERBOARD: ASRockRack ROMED8QM-2T
    BIOS Version: L1.21
    Chipset: AMD Starship/Matisse
    Network: 4 x Intel X710 for 10GbE SFP+ + 2 x Intel 10G X550T
    
    MEMORY: 8 x 16384 MB DDR4-3200MT/s Samsung M393A2K43DB3-CWE
    
    DISK: 10 x 4001GB INTEL SSDPE2KX040T8 + 1024GB KXG60ZNV1T02 TOSHIBA
    File-System: ext4
    Mount Options: relatime rw
    Disk Scheduler: NONE
    
    OPERATING SYSTEM: Ubuntu 20.04
    Kernel: 5.4.0-53-generic (x86_64)
    Compiler: GCC 9.3.0
    Security: itlb_multihit: Not affected
    + l1tf: Not affected
    + mds: Not affected
    + meltdown: Not affected
    + spec_store_bypass: Mitigation of SSB disabled via prctl and seccomp
    + spectre_v1: Mitigation of usercopy/swapgs barriers and __user pointer sanitization
    + spectre_v2: Mitigation of Full AMD retpoline IBPB: conditional IBRS_FW STIBP: conditional RSB filling
    + srbds: Not affected
    + tsx_async_abort: Not affected
    Last edited by Edur; 14 November 2020, 07:19 AM.
Working...
X