Announcement

Collapse
No announcement yet.

pts/namd, pts/apache failing on Windows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pts/namd, pts/apache failing on Windows

    Hi,

    Little heads up on 2 tests which are failing for me on Windows.

    pts/namd

    This was complaining about a missing dependency.
    cygcheck told me MSVCR100.dll was missing.
    Turns out that the link provided to download the VC++ 2010 runtime is for x86. You might want to update it for x64 as the majority of people will probably be running a 64-bit Windows:
    https://www.microsoft.com/en-us/down....aspx?id=13523

    After that, the test still fails, but with no output, and nothing in the log at all.
    I currently have no idea how to fix that.

    pts/apache

    The following command seems to make the pre-windows.sh script hang indefinitely:
    Code:
    ./httpd.exe &
    I'm guessing that despite the request to have it run as a background process, either the cygwin process or the bash process refuse to quit if there are still owned background processes running.

    After replacing it with the following line, the test could proceed as expected:
    Code:
    cygstart --hide ./httpd.exe
    However, the processes were not terminated at the end.
    Instead I got this output:
    Code:
    : arguments must be process or job IDstest-profiles/pts/apache-1.7.2/post_windows.sh: line 2: kill: 1316
    The culprit is the following line in post_windows.sh:
    Code:
    kill -TERM `cat $HOME/Apache24/logs/httpd.pid`
    I tried replacing it with the following commands that work when I test them directly in a cygwin prompt:
    Code:
    /bin/kill --winpid -f -TERM `cat $HOME/Apache24/logs/httpd.pid`
    (it has to be /bin/kill, not just kill, and without -f it still doesn't find the PID)
    But it says "illegal pid", apparently it doesn't have the rights to kill that PID. Could it be because the process was started with "cygstart"?
    Code:
    taskkill /F /PID `cat $HOME/Apache24/logs/httpd.pid`
    And that doesn't even find taskkill, because somehow the PATH variable only knows /usr/bin.
    If I specify the full path to taskkill, it still fails with "Invalid query"

    So I don't have any suggestion on how kill the process after the test.

  • #2
    I have created GitHub issues for these.
    You may delete this thread.

    Comment

    Working...
    X