Announcement

Collapse
No announcement yet.

john-the-ripper-1.6.2 doesn't install on systems with openssl 1.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • john-the-ripper-1.6.2 doesn't install on systems with openssl 1.1

    Hi,

    john-the-ripper-1.6.2 is using john-1.8.0-jumbo-1, as shown at https://openbenchmarking.org/innhold...1c9ef8f972764a

    https://github.com/magnumripper/John...er/issues/2355 was resolved at john-1.9.0-jumbo-1.

    Would you consider updating the pts/john-the-ripper test to using john-1.9.0-jumbo-1?

    Thanks,
    -James

  • #2
    Thanks for reporting jamesc ! I had been annoyed as well for a while JTR wasn't building against OpenSSL 1.1. I didn't realize though a new JTR update was released last month. I should be able to get the test profile updated this weekend.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Thanks Michael for your super quick response! Look forward to the new version of the JTR test.

      Comment


      • #4
        The updated test profile is now pushed out. It should be pts/john-the-ripper-1.7.0 that contains the new JtR. (If you used your PTS client in the past 24 hours you may need to manually run `phoronix-test-suite openbenchmarking-refresh` before running the john-the-ripper benchmark command will see the new version.)
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Wow, that's quick! It's working now. :-) Thank you so much, Michael, and you have a great weekend!

          Comment

          Working...
          X