Announcement

Collapse
No announcement yet.

Wrong Graphics card detected

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wrong Graphics card detected

    I have a machine which I'm using for ML experiments. I'm looking to use PTS to see whether or not the CPU is causing a bottleneck using standard Linux utils and PTS. However when I run 'phoronix-test-suite system-info' PTS doesn't seem to pick up the GPU. Instead it lists the discrete graphics card.


    HTML Code:
    Phoronix Test Suite v8.6.1
    System Information
    
    
      PROCESSOR:          Intel Core i5-4690K @ 3.90GHz
        Core Count:       4                                        
        Extensions:       SSE 4.2 + AVX2 + AVX + RDRAND + FSGSBASE 
        Cache Size:       6144 KB                                  
        Microcode:        0x25                                     
        Scaling Driver:   intel_pstate powersave                   
    
      GRAPHICS:           Intel Xeon E3-1200 v3/4th Gen Core IGP 8GB
        Frequency:        471/1001MHz      
        Display Driver:   NVIDIA 384.130   
    
      MOTHERBOARD:        Gigabyte Z97P-D3
        BIOS Version:     F8                        
        Chipset:          Intel 4th Gen Core DRAM   
        Audio:            Intel Xeon E3-1200 v3/4th 
        Network:          Realtek RTL8111/8168/8411 
    
      MEMORY:             32768MB
    
      DISK:               120GB Western Digital WDS120G2G0A + 4001GB Western Digital WD4002FYYZ-0
        File-System:      ext4                     
        Mount Options:    data=ordered relatime rw 
        Disk Scheduler:   CFQ                      
    
      OPERATING SYSTEM:   Ubuntu 18.04
        Kernel:           4.15.0-45-generic (x86_64)                                   
        Display Server:   X Server                                                     
        Compiler:         GCC 7.3.0 + CUDA 9.2                                         
        Security:         KPTI                                                         
                          + __user pointer sanitization                                
                          + Full generic retpoline IBPB IBRS_FW                        
                          + SSB disabled via prctl and seccomp                         
                          + PTE Inversion; VMX: conditional cache flushes SMT disabled 
    I have an NVIDIA GTX 1070 which is running fine for these experiments. Where does PTS pick up the configuration for which graphics module to use. Is it configurable? I couldn't see anything on the documentation for this so I assume this needs to be configured on the OS somewhere?

  • #2
    The main place it picks it up is glxinfo... Do you have glxinfo installed? (mesa-utils package on Ubuntu) otherwise it might end up just pulling the data from lspci. Also do you have nvidia-settings in your path?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Thanks for such a quick reply Michael

      I have mesa-utils installed. The output doesn't look correct

      HTML Code:
      name of display: localhost:10.0
      X Error of failed request:  BadValue (integer parameter out of range for operation)
        Major opcode of failed request:  154 (GLX)
        Minor opcode of failed request:  24 (X_GLXCreateNewContext)
        Value in failed request:  0x0
        Serial number of failed request:  41
        Current serial number in output stream:  42
      I also have nvidia-settings. Interestingly when I run it, the wrong GPU seems to be displayed. It's showing a GT 730M rather than a GTX 1070. So perhaps this is my problem if this is where the config is pulled from

      Comment


      • #4
        I have my suspicion that this is driver related. The error below creates some search hits that relate to driver/setting versions and nvidia/nouveau drivers. I might need to play about with the options here

        HTML Code:
        $nvidia-settings --glxinfo
        
        libEGL warning: DRI2: failed to authenticate
        X Error of failed request:  BadRequest (invalid request code or no such operation)
          Major opcode of failed request:  153 ()
          Minor opcode of failed request:  1
          Serial number of failed request:  48
          Current serial number in output stream:  48

        Comment

        Working...
        X