Announcement

Collapse
No announcement yet.

startup-time-1.3.0 not producing results

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • startup-time-1.3.0 not producing results

    Debug output:
    Code:
    ========================================
    Application Start-up Time (Run 1 of 1)
    ========================================
    
    
    Test Run Command: cd /home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/ &&  /usr/share/phoronix-test-suite/pts-core/static/root-access.sh ./startuptime-run rw gnome-terminal 2>&1
    
    
    This test requires root access to run.
    
    + [ rw = r ]
    + mix=5 5
    + comm=replay-startup-io gnometerm
    + mylog=/home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/tmplog
    + cd S-master
    + [ ! X = X ]
    + echo Invoking local dir
    + sed -i s<.*BASE_DIR=.*<BASE_DIR=$PWD/../workfiles< def_config_params.sh
    + cd comm_startup_lat
    + ./comm_startup_lat.sh  5 5 seq 3 replay-startup-io gnometerm
    + tail -n 1
    + tail -n 1
    + awk { printf "Average start-up time: %g\n",  $3 }
    + egrep Latency statistics -A 2 /home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/tmplog
    + rm /home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/tmplog
    
    Result Key: #_RESULT_#
    
    
    Template Line: Average start-up time: #_RESULT_#
    
    
    Result Parsing Search Key: "time:"
    
    
    Result Line:
    
    
    No Test Results
    
    
    The test run did not produce a result.
    
    
    Log File At: /home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/startup-time-1.3.0-1544042717-1.log
    The log file is empty. Any ideas?

  • #2
    Were you running as root? Otherwise paolo can hopefully comment.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      I think so. It asks me for the root password (sudo).
      Edit: forgot to mention OS. This is on Ubuntu 18.10.
      Edt2: the device under test is a bcache device (/dev/bcache0). It breaks the logic of computing the device on which the root directory is mounted. Complete bash debug output can be found in pastebin: https://pastebin.com/xqBiUsdz
      Code:
      +++ echo There is something wrong with the device /dev/block, which I have
      +++ echo computed as the device on which your root directory is mounted.
      +++ echo Try setting your target device manually in /home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0//.S-config.sh
      Last edited by Filiprino; 12-05-2018, 11:29 PM.

      Comment


      • #4
        Originally posted by Filiprino View Post
        I think so. It asks me for the root password (sudo).
        Edit: forgot to mention OS. This is on Ubuntu 18.10.
        Edt2: the device under test is a bcache device (/dev/bcache0). It breaks the logic of computing the device on which the root directory is mounted. Complete bash debug output can be found in pastebin: https://pastebin.com/xqBiUsdz
        Code:
        +++ echo There is something wrong with the device /dev/block, which I have
        +++ echo computed as the device on which your root directory is mounted.
        +++ echo Try setting your target device manually in /home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0//.S-config.sh
        Correct debugging: the suite has never been used on /dev/bcache. I have a few questions to help you. Most certainly, I'll have to update the test on phoronix. If you want to continue in private, please write to paolo.valente <at> linaro.org. Here are the questions:
        1) How did you select /dev/bcache as test device?
        2) What's the output of mount
        3) In particular, according to your complete output, the test files are created in
        /home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/S-master/comm_startup_lat/../workfiles
        is this directory in /dev/bcache0?
        4) What is the output of lsblk?

        Looking forward to these information for fixing the test.

        Comment


        • #5
          1) Changing the file ~/.S-config.sh and file ~/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/S-master/def_config_params.sh. Variable DEV set to bcache0 (not /dev/bcache0). If I only changed .S-config.sh, the test in ~/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/S-master/config_params.sh:17 fails. I noticed startuptime-run rewrites def_config_params.sh.
          2) https://pastebin.com/aTVTBUFv
          3) Yes. Bcache0 is used as root device.
          4) https://pastebin.com/xyfmN667
          Originally posted by paolo View Post
          Correct debugging: the suite has never been used on /dev/bcache. I have a few questions to help you. Most certainly, I'll have to update the test on phoronix. If you want to continue in private, please write to paolo.valente <at> linaro.org. Here are the questions:
          1) How did you select /dev/bcache as test device?
          2) What's the output of mount
          3) In particular, according to your complete output, the test files are created in
          /home/user/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/S-master/comm_startup_lat/../workfiles
          is this directory in /dev/bcache0?
          4) What is the output of lsblk?

          Looking forward to these information for fixing the test.
          I was thinking on using either the caching device or backing device, as the IO scheduler of DEV device is susceptible to being changed. But given the nature of Bcache which acts as a IO scheduler itself, I have used the virtual device bcache0
          Last edited by Filiprino; 12-06-2018, 10:20 PM.

          Comment


          • #6
            Originally posted by Filiprino View Post
            1) Changing the file ~/.S-config.sh and file ~/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/S-master/def_config_params.sh. Variable DEV set to bcache0 (not /dev/bcache0). If I only changed .S-config.sh, the test in ~/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/S-master/config_params.sh:17 fails. I noticed startuptime-run rewrites def_config_params.sh.
            2) https://pastebin.com/aTVTBUFv
            3) Yes. Bcache0 is used as root device.
            4) https://pastebin.com/xyfmN667


            I was thinking on using either the caching device or backing device, as the IO scheduler of DEV device is susceptible to being changed. But given the nature of Bcache which acts as a IO scheduler itself, I have used the virtual device bcache0
            Thanks for this information. Starting from it, I have extended the S benchmark suite (with which this phoronix test is made) so as to hopefully handle bcache devices too.

            Before I exploit this extension to make a new version of this phoronix test, could you please run the following very quick smoke test for me? It will execute the same code that will be executed in the phoronix test, but not wrapped into the latter. So, in case of mistakes, it will be much easier to solve them.

            Just do:
            git clone https://github.com/Algodev-github/S

            Then change the value of the parameter BASE_DIR in the file S/def_config.sh with the path of a directory contained in the filesystem cached by your bcache device. If you prefer to do it with just a command, the following should work:

            sed -i 's<BASE_DIR=.*<BASE_DIR=your-directory-in-bcache<'

            By doing so, the code of the suite will detect automatically all involved devices for you. This is easier and safer than setting these pair of devices manually through the parameter DEVS.

            Afte that, just do (to test the start-up time of gnome-terminal with 5 readers and 5 writers in the background):
            cd S/comm_startup_lat
            sudo ./comm_startup_lat.sh <the scheduler you want to test> 5 5 seq 3 "replay-startup-io gnometerm"

            and let me know if everything goes well. For a minimal comparison, you could, e.g., try first with none and then with bfq.

            Crossing my fingers ...

            Comment


            • #7
              Originally posted by Filiprino View Post
              1) Changing the file ~/.S-config.sh and file ~/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/S-master/def_config_params.sh. Variable DEV set to bcache0 (not /dev/bcache0). If I only changed .S-config.sh, the test in ~/.phoronix-test-suite/installed-tests/pts/startup-time-1.3.0/S-master/config_params.sh:17 fails. I noticed startuptime-run rewrites def_config_params.sh.
              2) https://pastebin.com/aTVTBUFv
              3) Yes. Bcache0 is used as root device.
              4) https://pastebin.com/xyfmN667


              I was thinking on using either the caching device or backing device, as the IO scheduler of DEV device is susceptible to being changed. But given the nature of Bcache which acts as a IO scheduler itself, I have used the virtual device bcache0
              Any plan to test my proposed commands? Sorry for pushing, but this would be a good useful occasion to fix this test.

              Comment


              • #8
                Sorry for the absence. I'm migrating the system to UEFI and I am dual booting with Windows, which is making things harder than what it should. :S

                Originally posted by paolo View Post

                Any plan to test my proposed commands? Sorry for pushing, but this would be a good useful occasion to fix this test.

                Comment

                Working...
                X