Announcement

Collapse
No announcement yet.

PTS - local run without internet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • supicek63
    started a topic PTS - local run without internet

    PTS - local run without internet

    I would like tu run PTS locally on multiple systems which do not have internet connection. I installed tests (CacheBench, Gzip Compression, IOzone, netperf) on system with internet connection and then run "./phoronix-test-suite make-download-cache". Then I copied download cache from /var/lib/phoronix-test-suite/download-cache to system without internet connection to same location. I tried to install the tests "./phoronix-test-suite install iozone" but all I got was "[PROBLEM] Invalid Argument: iozone". I tried to copy also test-profiles but it didn't make any difference.
    Both systems are SuSe linux enterprise 12 SP3 and I am using PTS 8.2 under root account. Could you please help me figure out what could be the problem here?
    Thanks in advance.

  • whitecat
    replied
    I'm running PTS 7.8.0 from the EPEL 7 repository.

    Yes /var/lib/phoronix-test-suite/test-profiles is full of files in pts and system subdirs (not in local though).

    Leave a comment:


  • Michael
    replied
    What version of PTS are you using? And do you see stuff in /var/lib/phoronix-test-suite/test-profiles?

    Leave a comment:


  • whitecat
    replied
    I didn't.
    So I did it, copied the whole directory to the offline machine but still have the errors:


    # phoronix-test-suite install pts/openssl


    No Internet Connectivity After Wait

    No Internet Connectivity After Wait

    [NOTICE] Failed To Fetch OpenBenchmarking.org Repository Data: pts

    [NOTICE] Failed To Fetch OpenBenchmarking.org Repository Data: system

    [PROBLEM] Invalid Argument: pts/openssl

    CORRECT SYNTAX:
    phoronix-test-suite install [Test | Suite | OpenBenchmarking ID | Test Result] ...


    Recently Saved Test Results:
    - gzip-test-laptop [Today]

    Leave a comment:


  • Michael
    replied
    Originally posted by whitecat View Post
    Hello,

    I have the same issue.
    I installed PTS and performed a benchmark on a machine with Internet connection. Everything is OK. I execute the make download cache command.
    then I copied the whole phoronix-test-suite dir (from var lib) to the offline machine and tried to run or install a benchmark but still complains about no Internet access...
    Did you also run make-openbenchmarking-cache before copying over the entire dir?

    Leave a comment:


  • whitecat
    replied
    Hello,

    I have the same issue.
    I installed PTS and performed a benchmark on a machine with Internet connection. Everything is OK. I execute the make download cache command.
    then I copied the whole phoronix-test-suite dir (from var lib) to the offline machine and tried to run or install a benchmark but still complains about no Internet access...

    Leave a comment:


  • supicek63
    replied
    I tried to copy the whole folder again and it's working now, I have a feeling that previous copied files were somehow corrupted. Even if I delete installed tests, installation from cache works now.
    Anyway thanks for your help.

    Leave a comment:


  • Michael
    replied
    Did you try copying the entire /var/lib/phoronix-test-suite folder?

    Leave a comment:


  • supicek63
    replied
    Hi Michael, thanks for the answer. I tried to copy test-profiles folder too, however I am still getting same error.

    Leave a comment:


  • Michael
    replied
    You also need to copy the /var/lib/phoronix-test-suite/test-profiles/ folder too in order to copy over the cached test profile (benchmark) metadata, just not the download-cache directory.

    Leave a comment:

Working...
X