Announcement

Collapse
No announcement yet.

pts/hpcc will not install on Ubuntu 18.04, PTS 8.0

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • pts/hpcc will not install on Ubuntu 18.04, PTS 8.0

    On Phoronix Test Suite 8.0.0, I tried to install the hpcc test, and it gives an error. This is a fresh copy of PTS 8.0.0, downloaded as a Debian package from phoronix-test-suite.com. I am using Ubuntu Mate 18.04. After installing, I ran
    phoronix-test-suite benchmark pts/hpcc

    It then tries to install the test. During the installation process, the terminal produces the following error:

    The installer exited with a non-zero exit status.
    ERROR: collect2: error: ld returned 1 exit status
    LOG: ~/.phoronix-test-suite/installed-tests/pts/hpcc-1.2.2/install-failed.log


    [PROBLEM] pts/hpcc-1.2.2 is not installed.

    [PROBLEM] You must enter at least one test, suite, or result identifier to run.

  • #2
    What does ~/.phoronix-test-suite/installed-tests/pts/hpcc-1.2.2/install-failed.log say?

    Comment


    • #3
      It is a big file with 1398 lines and a lot of text. I tried pasting the whole thing into this post, but the forum software says it exceeds the character limit.

      Comment


      • #4
        You have several options:
        1. look in the file, maybe you will be able to identify the error by yourself and fix it, maybe you will need to google it.
        2. post link to https://pastebin.com/ with your log.

        Comment


        • #5
          Here's a Pastebin link:
          https://pastebin.com/HeRXEkSX

          Comment


          • #6
            If yuou try again, pts/hpcc-1.2.3 is now the latest version that will automatically be used and it has a build script fix for Ubuntu 18.04.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Thank you, it works now.

              Comment

              Working...
              X