Announcement

Collapse
No announcement yet.

How to debug "The test run did not produce a result."?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to debug "The test run did not produce a result."?

    I tried running "phoronix-test-suite benchmark 1611281-TA-DARKTABLE97" where the darktable was compiled in my Workstation. The binary is in the path.

    How do I debug the output below? I tried the forum but could not find a proper answer.

    ****************************** OUTPUT ******************************

    [email protected]:~$ phoronix-test-suite benchmark 1611281-TA-DARKTABLE97

    Phoronix Test Suite v5.2.1

    Installed: system/darktable-1.0.0

    System Information

    Hardware:
    Processor: Intel Core i5-6600 @ 3.90GHz (4 Cores), Motherboard: ASUS Z170M-PLUS/BR, Chipset: Intel Skylake /DRAM, Memory: 16384MB, Disk: 2 x 2000GB Western Digital WD20EFRX-68A + 120GB KINGSTON SH103S3 + 500GB Western Digital WD5000AAKS-0 + 500GB Western Digital WD5000AAKX-0, Graphics: Gigabyte NVIDIA GeForce GTX 650 2048MB (1110/2500MHz), Audio: Realtek ALC887-VD, Network: Intel Connection + Broadcom Limited BCM4360 802.11ac Wireless

    Software:
    OS: Ubuntu 18.04, Kernel: 4.15.0-22-generic (x86_64), Desktop: Xfce 4.12, Display Driver: NVIDIA 390.48, OpenGL: 4.6.0, File-System: zfs, Screen Resolution: 2560x1440


    Current Test Identifiers:
    - Intel Xeon E3-1280 v5 (CPU Only)
    - GeForce GTX 680
    - GeForce GTX 780 Ti
    - GeForce GTX 950
    - GeForce GTX 960
    - GeForce GTX 970
    - GeForce GTX 980
    - GeForce GTX 980 Ti
    - GeForce GTX 1050
    - GeForce GTX 1050 Ti
    - GeForce GTX 1060
    - GeForce GTX 1070
    - GeForce GTX 1080
    - Radeon R7 260X
    - Radeon R9 285
    - Radeon R9 290
    - Radeon RX 460
    - Radeon RX 470
    - Radeon RX 480
    - Radeon R9 Fury
    - GeForce GTX 650

    Enter a unique name to describe this test run / configuration:

    If you wish, enter a new description below to better describe this result set / system configuration under test.
    Press ENTER to proceed without changes.

    Current Description: Running system/darktable-1.0.0 via the Phoronix Test Suite.

    New Description:


    Darktable 2.2.0~rc1:
    system/darktable-1.0.0 [Test: Boat - Acceleration: OpenCL]
    Test 1 of 3
    Estimated Trial Run Count: 3
    Estimated Test Run-Time: 2 Minutes
    Estimated Time To Completion: 4 Minutes
    Started Run 1 @ 18:51:13
    The test run did not produce a result.
    Started Run 2 @ 18:51:43
    The test run did not produce a result.
    Started Run 3 @ 18:52:06
    The test run did not produce a result.

    Test Results:

    Average: 0 Seconds
    This test failed to run properly.

    [NOTICE] Parameter 1 to graphics_event_checker::__post_test_run() expected to be a reference, value given in pts_module_manager:74

    [NOTICE] count(): Parameter must be an array or an object that implements Countable in pts_test_run_manager:611


    Darktable 2.2.0~rc1:
    system/darktable-1.0.0 [Test: Masskrug - Acceleration: OpenCL]
    Test 2 of 3
    Estimated Trial Run Count: 3
    Estimated Test Run-Time: 2 Minutes
    Estimated Time To Completion: 3 Minutes
    Started Run 1 @ 18:52:36
    The test run did not produce a result.
    Started Run 2 @ 18:52:53
    The test run did not produce a result.
    Started Run 3 @ 18:53:12
    The test run did not produce a result.

    Test Results:

    Average: 0 Seconds
    This test failed to run properly.

    [NOTICE] Parameter 1 to graphics_event_checker::__post_test_run() expected to be a reference, value given in pts_module_manager:74

    [NOTICE] count(): Parameter must be an array or an object that implements Countable in pts_test_run_manager:611


    Darktable 2.2.0~rc1:
    system/darktable-1.0.0 [Test: Server Room - Acceleration: OpenCL]
    Test 3 of 3
    Estimated Trial Run Count: 3
    Estimated Time To Completion: 2 Minutes
    Started Run 1 @ 18:53:33
    The test run did not produce a result.
    Started Run 2 @ 18:53:47
    The test run did not produce a result.
    Started Run 3 @ 18:53:59
    The test run did not produce a result.

    Test Results:

    Average: 0 Seconds
    This test failed to run properly.

    [NOTICE] Parameter 1 to graphics_event_checker::__post_test_run() expected to be a reference, value given in pts_module_manager:74

    [NOTICE] count(): Parameter must be an array or an object that implements Countable in pts_test_run_manager:611


    The following tests failed to properly run:

    - system/darktable-1.0.0: Test: Boat - Acceleration: OpenCL
    - system/darktable-1.0.0: Test: Masskrug - Acceleration: OpenCL
    - system/darktable-1.0.0: Test: Server Room - Acceleration: OpenCL


    Do you want to view the results in your web browser (Y/n): y
    Would you like to upload the results to OpenBenchmarking.org (Y/n): n




  • #2
    phoronix-test-suite debug-run darktable

    for getting the debugging output.

    Also I would suggest first of all upgrading to the latest PTS 7.8/8.0m5 as v5.2.1 is years outdated and not recommended. Upgrading to the latest PTS may very well fix your problem right away.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      After debugging a bit I realized that my log file shows extra timing before the [dev_pixelpipe] string, so I added x.xxx to the results-definition.xml, like below:

      <OutputTemplate>x.xxx [dev_process_export] pixel pipeline processing took #_RESULT_# secs (72.368 CPU)

      Comment

      Working...
      X