Announcement

Collapse
No announcement yet.

How to get system sensors to work in a test

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to get system sensors to work in a test

    I am probably missing something stupid but I can't seem to figure out how to run a test with the system_monitor module. I am able to execute "phoronix-test-suite system-sensors" and it shows the info that I want.

    But when I run "monitor=all phoronix-test-suite run pts/unigine-valley" I get "Unloading system monitor: No Supported Sensors Selected To Monitor".

    Also when I run "phoronix-test-suite test-module system_monitor" I get:
    Calling: __startup()
    Calling: __pre_option_process()
    Calling: __pre_install_process()
    Calling: __pre_test_download()
    Calling: __interim_test_download()
    Calling: __post_test_download()
    Calling: __pre_test_install()
    Calling: __post_test_install()
    Calling: __post_install_process()
    Calling: __pre_run_process()
    PHP Fatal error: Uncaught Error: Call to a member function get_results_identifier() on null in /usr/share/phoronix-test-suite/pts-core/modules/system_monitor.php:83
    Stack trace:
    #0 /usr/share/phoronix-test-suite/pts-core/objects/client/pts_module_manager.php(85): system_monitor::__pre_run_process(NULL)
    #1 /usr/share/phoronix-test-suite/pts-core/objects/client/pts_module_manager.php(107): pts_module_manager::module_call('system_monitor', '__pre_run_proce...', NULL)
    #2 /usr/share/phoronix-test-suite/pts-core/commands/test_module.php(45): pts_module_manager::module_process('__pre_run_proc e...')
    #3 /usr/share/phoronix-test-suite/pts-core/objects/client/pts_client.php(1300): test_module::run(Array)
    #4 /usr/share/phoronix-test-suite/pts-core/phoronix-test-suite.php(181): pts_client::execute_command('test_module', Array)
    #5 {main}
    thrown in /usr/share/phoronix-test-suite/pts-core/modules/system_monitor.php on line 83

    I tested on Fedora 27 and Ubuntu 18.04.
Working...
X