Announcement

Collapse
No announcement yet.

Valve Reports Steam Linux Usage Fell Further In March

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kano
    replied
    @debainxfce

    1% of 1 core, not that I laugh...

    Leave a comment:


  • cj.wijtmans
    replied
    You may also want to check if you get this message
    "# dmesg | grep bdl_pos_adj
    [ 24.958540] snd_hda_intel 0000:00:1b.0: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
    "

    show current values:
    "# cat /sys/module/snd_hda_intel/parameters/bdl_pos_adj
    32,-1,-1,-1,-1,-1,-1,-1"


    then:
    "nano /etc/modprobe.d/alsa.conf
    "options snd-hda-intel bdl_pos_adj=48"

    (if you still get it try 60 or 64)

    it will cause pulseaudio timing issues if you dont fix this.

    (why the kernel doesnt do this automatically is beyond me, -1 is suposed to be automatic :S )
    Last edited by cj.wijtmans; 03 April 2016, 10:45 AM.

    Leave a comment:


  • Kano
    replied
    Default settings often work, but newer KDE versions need device setup inside the KDE settings to work after reboot instead of pure pavucontrol. That's maybe a bit tricky but sound delay is most likely a (manual) config issue or some distros use weird defaults. It must be something like that as some Arch users seem to prefer a very special PA config and have got more problems than the rest.

    Leave a comment:


  • geearf
    replied
    Originally posted by dimko View Post
    I would, but skype... YOu ignore this = 0 social life.
    And every now and then really good games on Steam pop up that dont work on ALSA. Pulse is a fucking cancer.
    I haven't used Skype since 2005, when it was the only VOIP software not blocked by my campus.
    My social life does not suffer of anything because of it (it'd be FB for me actually...)

    Originally posted by dimko View Post

    I lived in 4 countries not counting where I come from by age of 32, can you say same about you?
    Yes I can, and yes it would be true.
    Last edited by geearf; 02 April 2016, 08:13 PM.

    Leave a comment:


  • geearf
    replied
    Originally posted by wodencafe View Post

    Yes and no, I imagine a lot of Linux Steam gamers are in a position like myself, where there are some games that work better in the native Linux Steam client, and others that work better (or only work) in Wine Steam.



    Let's be real, Wine for gaming is a D3D -> OpenGL translation layer, and you don't get that for free.

    If all the Steam games functioned correctly in Linux Steam AND Wine Steam, I would use Linux Steam because as a gamer, because I want the best performance. That's the incentive.

    That, and modern cross platform game engines make it so easy to target multiple platforms now. Even just a 1% market share is a lot of $ for a big game title.

    The other unfortunate aspect of having to bring in Wine, and I hate to say this, but it's adding yet another member to the group of "entities that have to work together to make the game run".

    So we have Linux, Mesa, Steam, The Game, and Wine. It's another point of failure.
    You;re looking at it from a user's perspective, I was looking at it from the other side.

    Leave a comment:


  • sterky
    replied
    Originally posted by smilzoboboz View Post
    I don't really know what's wrong with my setup... I'm running Arch, with a years old alsa configuration for playback, mic recording, snd-aloop playback recording and an alternative playback sink not recorded by snd-aloop.

    With recent Unity5 games I experienced crashes on game loading so I decided it was time to move to pulseaudio, and I failed:
    After removing snd-aloop from loaded modules, removing ~/.asoundrc, installing alsa-pulse (which creates an additional file with pulse alsa sinks), pulseaudio ended up using 3%~5% of the total time of my AMD FX-8350 (the most cpu-intensive background program on my setup and by far). But, well, that aside I'm also getting an annoying delay (like ~0.5 s) on playback.
    I tried to lower the samples (on the config files) to mitigate the delay, but that changed nothing.

    Right now I ended up doing this ugly thing: my old ALSA-only setup, running pulseaudio within alsa (pointing to my custom dmix instead of the actual hardware) only when I need it. All my Unity5 games had their execution line changed to pulseaudio --start; %command%; pulseaudio --kill.
    No need to say that I'm still getting that 0.5 s delay on playback on these games, and it really sucks...

    If you have some magic hint to throw, please throw it, kung fury with 0.5 s sound delay is unplayable.

    Hi, you might want to test your game with PULSE_LATENCY_MSEC=value (example PULSE_LATENCY_MSEC=20), export it berfore or add to launch command in steam.
    For some reason unity games, probably unity4, and GRID autosport, crackle and distort audio for me, so adding PULSE_LATENCY_MSEC=60 %command% to steam game launch command, seem to help for that, maybe also for you.

    Edit: Don't get me wrong, if i understand correctly this is something, the client talking to pulseaudio needs to specify, so it's not the fault of pulse, but rather the client to specify the latency that it needs.
    Last edited by sterky; 02 April 2016, 08:22 PM.

    Leave a comment:


  • Kano
    replied
    You can try Kanotix Spitfire 64 Special in gfxdetect mode (for binary drivers) and run steam within your home even in live mode to see if your problem is specific to your install. The ISO is hybrid, put it 1:1 onto USB key.

    Leave a comment:


  • smilzoboboz
    replied
    Originally posted by Farmboy0 View Post
    As for pulseaudio while I am not exactly a fan it does work very well *if* you configure it correctly.
    But in order to do that you need to understand how pulse works and your own workflow.
    For starters I would try the ArchLinux wiki and their Troubleshooting page:
    https://wiki.archlinux.org/index.php/PulseAudio
    https://wiki.archlinux.org/index.php...roubleshooting
    I don't really know what's wrong with my setup... I'm running Arch, with a years old alsa configuration for playback, mic recording, snd-aloop playback recording and an alternative playback sink not recorded by snd-aloop.

    With recent Unity5 games I experienced crashes on game loading so I decided it was time to move to pulseaudio, and I failed:
    After removing snd-aloop from loaded modules, removing ~/.asoundrc, installing alsa-pulse (which creates an additional file with pulse alsa sinks), pulseaudio ended up using 3%~5% of the total time of my AMD FX-8350 (the most cpu-intensive background program on my setup and by far). But, well, that aside I'm also getting an annoying delay (like ~0.5 s) on playback.
    I tried to lower the samples (on the config files) to mitigate the delay, but that changed nothing.

    Right now I ended up doing this ugly thing: my old ALSA-only setup, running pulseaudio within alsa (pointing to my custom dmix instead of the actual hardware) only when I need it. All my Unity5 games had their execution line changed to pulseaudio --start; %command%; pulseaudio --kill.
    No need to say that I'm still getting that 0.5 s delay on playback on these games, and it really sucks...

    If you have some magic hint to throw, please throw it, kung fury with 0.5 s sound delay is unplayable.

    Leave a comment:


  • Kano
    replied
    @theriddick

    You need to OC the 6 core CPUs, the default speed is pretty low compared to the 4 core consumer ones.

    Leave a comment:


  • duby229
    replied
    Originally posted by dimko View Post

    I lived in 4 countries not counting where I come from by age of 32, can you say same about you? Thought so. And no, most people do use skype. Nothing to do with intelligence.
    I do admit I don't have any wordly experience. I've only lived within the states. And I guess because of that I've never had any problems staying in close touch with friends and family.

    Leave a comment:

Working...
X