Announcement

Collapse
No announcement yet.

Don't Use Fedora's Fedup Right Now Due To A Bug With Systemd

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Don't Use Fedora's Fedup Right Now Due To A Bug With Systemd

    Phoronix: Don't Use Fedora's Fedup Right Now Due To A Bug With Systemd

    While Fedora 21 Beta is coming next week, if you're wanting to upgrade early to the Fedora 21 packages, it's advised right now against using Fedora's upgrade utility (Fedup) unless you want to potentially trash your system...

    http://www.phoronix.com/vr.php?view=MTgyNzY

  • #2
    I bet we are told its just a "you are holding it wrong" since systemd is without any failures at all.

    Comment


    • #3
      This is a problem with Fedora's SystemD flags. Not SystemD.
      That option never should have been enabled in the first place. It is not the OSes responsibility to make sure you didn't leave your laptop under a pillow with the thermal safety's off.

      This is also in pre release/testing. Bugs are expected.
      Last edited by grndzro; 01 November 2014, 08:04 AM.

      Comment


      • #4
        Originally posted by k1l_ View Post
        I bet we are told its just a "you are holding it wrong" since systemd is without any failures at all.
        I think it's definitely a 'feature' (e.g. NOTABUG, WONTFIX).
        Normally I would say that LP would have dismissed it instantly, but since LP & co work for fedora, LP might get forced to 'fix it'.

        "What happens when an unstoppable force (RH) meets an immovable object (LP)?"
        *grabs popcorn*

        Comment


        • #5
          Originally posted by grndzro View Post
          This is a problem with Fedora's SystemD flags. Not SystemD.
          That option never should have been enabled in the first place. It is not the OSes responsibility to make sure you didn't leave your laptop under a pillow with the thermal safety's off.

          This is also in pre release/testing. Bugs are expected.
          Being sensible isn't allowed. We don't want your kind here.

          Comment


          • #6
            Originally posted by grndzro View Post
            This is a problem with Fedora's SystemD flags. Not SystemD.
            That option never should have been enabled in the first place. It is not the OSes responsibility to make sure you didn't leave your laptop under a pillow with the thermal safety's off.

            This is also in pre release/testing. Bugs are expected.
            So.....if the thermal's fail because of crappy BIOS/UEFI and then damages the hardware because the laptop wake up inside a case for some reason. Yeah i see that noone will blame the OS when it probably will shut down in Windows while it burns up in Linux.

            Comment


            • #7
              Originally posted by Commander View Post
              So.....if the thermal's fail because of crappy BIOS/UEFI and then damages the hardware because the laptop wake up inside a case for some reason. Yeah i see that noone will blame the OS when it probably will shut down in Windows while it burns up in Linux.
              You have crappy hardware when it overheats at maximum load, it's really frustrating when you see some high end laptops when the got ~90C at maximum load , good that are still custom PC when can you design it that it will never overheat.

              Comment


              • #8
                Originally posted by Commander View Post
                So.....if the thermal's fail because of crappy BIOS/UEFI and then damages the hardware because the laptop wake up inside a case for some reason. Yeah i see that noone will blame the OS when it probably will shut down in Windows while it burns up in Linux.
                That is a strawman argument.
                Problems like that result in recalls and lawsuits, and are almost always weeded out in QC.

                Comment


                • #9
                  Originally posted by grndzro View Post
                  This is a problem with Fedora's SystemD flags. Not SystemD.
                  That option never should have been enabled in the first place. It is not the OSes responsibility to make sure you didn't leave your laptop under a pillow with the thermal safety's off.

                  This is also in pre release/testing. Bugs are expected.
                  No, actually it isn't. The blog post in question, as well as Michael's article seem to have skipped over the actual bug report:

                  https://bugzilla.redhat.com/show_bug.cgi?id=1154768

                  The idea is that the timeout is supposed to be interruptible for certain startup items but the systemd option that allows you to disable the timeout is currently not functioning. Patches have been submitted upstream and I assume it will be fixed shortly, if not already.

                  Comment


                  • #10
                    this news is 24h late for me...
                    got cut half way with all packages installed twice... a merry mess
                    had to dl the beta iso and install clean ; I had intended to install fresh anyway since a long time but kept updating since fedora 16 (so lazy ) so it may have been a good thing in the end

                    Comment

                    Working...
                    X