Announcement

Collapse
No announcement yet.

The Fastest Linux Distributions For Web Browsing - Firefox + Chrome Benchmarks On Eight Distros

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Originally posted by Compartmentalisation View Post
    What's the recommended way of checking this?
    to check:
    cpupower frequency-info
    to change:
    cpupower frequency-set <setting>
    Setting is usually either "powersave" or "performance", although you could have others. Get this info from the cpupower frequency-info command.
    https://doc.opensuse.org/documentati...tools.cpupower

    Comment


    • #42
      Originally posted by SyXbiT View Post
      After having used Chrome for ~8 years, I thought now would be a good time to switch back to Firefox. However, Firefox on Linux scrolls terribly (Arch Linux). I get there are fixes for smooth scrolling, but why in 2019 doesn't Firefox on Linux have good defaults that don't require tweaking.
      I see what I would call Firefox scrolling issues varying depending on compositor and window manager. Most apparent in XFCE/xfwm. Least apparent on Gnome/mutter (and Cinnamon). I see it in MATE/Marco, less on Fedora than Ubuntu. I’ve seen it be very bad on KDE/Kwin Nividia.

      I bump mousewheel.min from 5 to 60 which helps.

      Comment


      • #43
        Originally posted by andyprough View Post

        to check:
        cpupower frequency-info
        to change:
        cpupower frequency-set <setting>
        Setting is usually either "powersave" or "performance", although you could have others. Get this info from the cpupower frequency-info command.
        https://doc.opensuse.org/documentati...tools.cpupower
        Thanks Andy, I'll check within 24 hours.

        Originally posted by duby229 View Post

        Oh, I'm pretty certain they must know themselves that they have made some extremely retarded decisions. Not enabling -xrender- of all things must be among the very top of those.
        Nah nah, you'll actually have to get away from your keyboard and tell them up close that they're retarded. Else you're just a bad programmer who's deflecting. Gotta back up your statements.

        Comment


        • #44
          Originally posted by andyprough View Post

          I see, I've been sticking with Mate for awhile now, and KDE before that. Am I right that XFCE development is sort of stalled? I think that was the last DE where I had significant Firefox problems, but it's been quite a few years since I tried XFCE. I used to run an FSF-approved Arch spin called Parabola, but everything seemed to work fine with that.
          I wouldn't say that it's stalled, they're just low on man power. I was using XFCE with as many gtk3 packages as Manjaro had available and it really wasn't that bad after making an xorg.conf; it's just that after using DEs like Mate, Plasma, & Budgie I realized that I just didn't care for XFCE anymore.

          Comment


          • #45
            Originally posted by Compartmentalisation View Post

            What's the recommended way of checking this?
            sudo cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

            It's a bit more complicated to permanently change the governor. Last I read you're supposed to create a systemd service unit to set it on boot every time.

            Comment


            • #46
              Originally posted by andyprough View Post

              to check:
              cpupower frequency-info
              to change:
              cpupower frequency-set <setting>
              Setting is usually either "powersave" or "performance", although you could have others. Get this info from the cpupower frequency-info command.
              https://doc.opensuse.org/documentati...tools.cpupower
              One of the first things I do post-install is to install that package and enable its systemd service to use the scheduitl governor since it works well with my westmere...and GameMode to switch to performance when gaming of course.

              Comment


              • #47
                Originally posted by sb56637 View Post

                sudo cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

                It's a bit more complicated to permanently change the governor. Last I read you're supposed to create a systemd service unit to set it on boot every time.
                Both Feral's GameMode and cpupower have systemd units that do just that and they work great together. cpupower sets it on boot and GameMode switches from one governor to another when you start and stop a game. Set GameMode's default governor to whatever you use in cpupower.

                Comment


                • #48
                  Originally posted by Compartmentalisation View Post

                  Thanks Andy, I'll check within 24 hours.



                  Nah nah, you'll actually have to get away from your keyboard and tell them up close that they're retarded. Else you're just a bad programmer who's deflecting. Gotta back up your statements.
                  Unless you use nVidia or something really old chances are highly likely you're using glamor to provide xrender acceleration.... It's what basically all of the OSS drivers use and I don't think -anybody- would make the claim that glamor is so buggy that firefox should have xrender acceleration disabled. That would be retarded, hence my entire point.....

                  Comment


                  • #49
                    Originally posted by duby229 View Post

                    It's because mozilla are retards and you have to open about:config in a tab and enable xrender acceleration.
                    That's it! I just enabled it and there's a huge difference. Why on earth wouldn't this be default!

                    Comment


                    • #50
                      Originally posted by SyXbiT View Post

                      That's it! I just enabled it and there's a huge difference. Why on earth wouldn't this be default!
                      .....

                      Originally posted by duby229 View Post

                      Unless you use nVidia or something really old chances are highly likely you're using glamor to provide xrender acceleration.... It's what basically all of the OSS drivers use and I don't think -anybody- would make the claim that glamor is so buggy that firefox should have xrender acceleration disabled. That would be retarded, hence my entire point.....

                      Comment

                      Working...
                      X