Originally posted by eltomito
View Post
AFS For Linux 5.1 Would Have Pleased Firefox/SQLite But Was Rejected As Untested Crap
Collapse
X
-
From our friends at Wikipedia:
Origin of the word "crap"
It has often been claimed in popular culture that the slang term for human bodily waste, crap, originated with Thomas Crapper because of his association with lavatories. A common version of this story is that American servicemen stationed in England during World War I saw his name on cisterns and used it as army slang, i.e. "I'm going to the crapper".[12]
The word crap is actually of Middle English origin and predates its application to bodily waste. Its most likely etymological origin is a combination of two older words, the Dutch krappen: to pluck off, cut off, or separate; and the Old French crappe: siftings, waste or rejected matter (from the medieval Latin crappa, chaff).[12] In English, it was used to refer to chaff, and also to weeds or other rubbish. Its first application to bodily waste, according to the Oxford English Dictionary, appeared in 1846 under a reference to a crapping ken, or a privy, where ken means a house.[12]
Comment
-
-
Originally posted by brrrrttttt View PostAussie, where overt racism is all good, and calling everyone c**t is fine, but crap is a swear word.
As to the racism, i cant deny that one but I would say most of us are less racist than Americans.
Comment
-
-
Well I don't know the part of the code Linus rejected, but an "uninitialized" warning doesn't always mean the code is buggy:
Code:int find_min(unsigned a[ELEMS]) { unsigned i_min, min = UINT_MAX; for (int i = 0; i < ELEMS; i++) if (a[i] <= min) { min = a[i]; i_min = i; } return i_min; }
Last edited by George99; 18 March 2019, 08:18 AM.
Comment
-
-
Originally posted by George99 View PostWell I don't know the part of the code Linus rejected, but an "uninitialized" warning doesn't always mean the code is buggy:
Code:int find_min(unsigned a[ELEMS]) { unsigned i_min, min = UINT_MAX; for (int i = 0; i < ELEMS; i++) if (a[i] <= min) { min = a[i]; i_min = i; } return i_min; }
I think it's bad practise to write:
unsigned i_min, min = UINT_MAX;
I know only min is initialized, but at a glance, it's easy to imagine that a developer could assume that both i_min and min are initialized to the value UINT_MAX.
I think it's better to write:
Code:unsigned i_min; unsigned min = UINT_MAX;
Comment
-
Comment