Announcement

Collapse
No announcement yet.

Google Still Doesn't Trust Linux GPU Drivers Enough To Enable Chrome Video Acceleration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Isn't what they're talking about true for pretty much anything that relies on vendor-supplied or supported drivers? Because that kind of excludes all hardware acceleration apart from what's supported directly by the compiler.

    However in their defense they are at least consistent on this subject seeing how they don't support 4k and HDR on Netflix as the browser implementation used by Netflix relies on Intel's combination of DRM and hardware acceleration. Apparently the only browsers to support the necessary DRM and hardware acceleration are Safari (ugh) and Edge (double ugh).
    "Why should I want to make anything up? Life's bad enough as it is without wanting to invent any more of it."

    Comment


    • #22
      Originally posted by carewolf View Post
      Anyway, last time I enabled it for QtWebEngine, it worked on my machine for some codecs but not for others, and other peoples machine, the codecs that worked and those that didn't were different. It is a mess of what works and what doesn't.
      The EGL implementation in mpv should work with every codec and format that is supported by the driver.
      I also wouldn't be surprised if it's once again about EGL vs. GLX in Chromium.

      Comment


      • #23
        Yeah it's just a fact. Go and enable it manually and see what happens. On some hardware / software / workload combinations it works fine. On others it crashes or hangs the system after a while. Not just video decoding. Also stuff like 3D in a browser (try in-browser 3D home planning tools).

        Comment


        • #24
          I don't understand why distro maintainers don't enable OpenMAX when they build chromium
          AMD has openmax
          Intel also
          nvidia provide openmax libraries for ARM base SOC so,

          Comment


          • #25
            Originally posted by L_A_G View Post
            Isn't what they're talking about true for pretty much anything that relies on vendor-supplied or supported drivers? Because that kind of excludes all hardware acceleration apart from what's supported directly by the compiler.

            However in their defense they are at least consistent on this subject seeing how they don't support 4k and HDR on Netflix as the browser implementation used by Netflix relies on Intel's combination of DRM and hardware acceleration. Apparently the only browsers to support the necessary DRM and hardware acceleration are Safari (ugh) and Edge (double ugh).
            AFAIK Chrome can show 4K Netflix on Windows with a Kaby Lake or newer Intel CPU, and on newer ChromeCast devices, so they have the code.

            Comment


            • #26
              Originally posted by GraysonPeddie View Post
              Then I'll definitely go with AMD with VA-API support. Sorry, but I could care less about NVDEC decoder. I'm using Firefox, by the way.
              "Linux on the desktop is essentially broken but I feel good about myself because I use it with a dozen of hacks to make the Linux experience bearable" - every Linux user.

              I just don't understand why ya'll are feeling all dandy about that.

              It's pathetic and miserable.

              Comment


              • #27
                As others had said, just leave the option to enable it in chrome://flags, under a experimental flag. That way users will not complain if something go wrong.

                Comment


                • #28
                  Originally posted by WolfpackN64 View Post
                  That's funny. I still don't trust Google enough to use their services.
                  "I'm a privacy obsessed idiot who wants to look all smart and cool that's why I will say something completely irrelevant because I can".

                  Comment


                  • #29
                    Originally posted by WolfpackN64 View Post

                    Except in actuality they work just fine, unless you have an Nvidia card on system without an easy installation path for their cards, which is NVIDIA's fault.
                    Video HW acceleration works just fine on AMD/Intel? Using which API? Using which version of this API?

                    There's no need to be retarded when you can just accept that video HW acceleration in Linux is a fucking mess.

                    Comment


                    • #30
                      Originally posted by birdie View Post

                      "Linux on the desktop is essentially broken but I feel good about myself because I use it with a dozen of hacks to make the Linux experience bearable" - every Linux user.

                      I just don't understand why ya'll are feeling all dandy about that.

                      It's pathetic and miserable.
                      I do a install of Kubuntu 18.04 and have a full supported system, fully updated and without any hacks, in less than 30 minutes. I don't remember that happening on Windows.

                      I also can do a list of things that, as a Linux user, pisses me off to no end when I have to use Windows, so I don't.

                      And as my ass don't print money, I keep my distance from Apple products.

                      If your experience on Linux is bad, don't assume everybody else to be the same.

                      Comment

                      Working...
                      X