Announcement

Collapse
No announcement yet.

X.Org Server 1.19.1 For Testing On Arch, Libinput X.Org Driver To Be Used By Default

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tyler_K
    replied
    Originally posted by RealNC View Post
    Did you recompile? If not, then that means you're using a binary that was built against evdev.

    Building KDE without evdev support results in no mouse options.
    I'm not familiar with the compilation of it, but are you talking build options for evdev the xorg input driver or against evdev the protocol? If the latter, it would be surprising if it worked with any input device afterwards (i.e. you want the evdev protocol)

    Leave a comment:


  • RealNC
    replied
    Originally posted by ⲣⲂaggins View Post

    I don't have that problem in xorg+synaptics nor wayland+libinput, so must be something else.
    Did you recompile? If not, then that means you're using a binary that was built against evdev.

    Building KDE without evdev support results in no mouse options.

    Leave a comment:


  • Tyler_K
    replied
    Originally posted by RealNC View Post
    It doesn't exist if you use libinput. In system settings -> input devices, the mouse icon is missing:
    ...
    You can only configure keyboard and joystick. Not the mouse.
    As the prior poster noted, it must be something else. I'm (exclusively) using the libinput xorg driver and I have the keyboard, mouse, joystick and touchpad all present.

    In addition, on my laptop (which is also exclusively using the libinput driver for the varing input devices), the touchpad sensitivity slider setting works (which I know others have reported to be greyed out whether in the systemsettings or the kcm).

    Last edited by Tyler_K; 17 January 2017, 12:18 AM.

    Leave a comment:


  • ⲣⲂaggins
    replied
    Originally posted by RealNC View Post
    It doesn't exist if you use libinput. In system settings -> input devices, the mouse icon is missing:

    http://i.imgur.com/91Z3J5Dm.png

    You can only configure keyboard and joystick. Not the mouse.
    I don't have that problem in xorg+synaptics nor wayland+libinput, so must be something else.

    Leave a comment:


  • RealNC
    replied
    Originally posted by ⲣⲂaggins View Post

    What's this?

    It doesn't exist if you use libinput. In system settings -> input devices, the mouse icon is missing:



    You can only configure keyboard and joystick. Not the mouse.

    Leave a comment:


  • GrayShade
    replied
    Originally posted by pejakm View Post
    Last commit was in 2015. Not that I particularly care about KDE, but does that thing still work?
    Last edited by GrayShade; 16 January 2017, 12:09 PM.

    Leave a comment:


  • pejakm
    replied
    For KDE you have this: https://github.com/amezin/pointing-devices-kcm

    Leave a comment:


  • carewolf
    replied
    Bloody hell, now Debian testing changed as well. Gone is the xinput2 scrolling distance setting, no more smooth wheel scrolling (no, changing udev hwdb settings does nothing).

    Leave a comment:


  • magika
    replied
    Originally posted by ⲣⲂaggins View Post

    By 'support' I take it you mean 'ability to configure', not 'use as input driver'?

    I'm also having a hard time believing what you wrote, as the workaround with xinput set-prop wouldn't make sense in that case.
    You are correct, kcm works just fine under X.

    Leave a comment:


  • ⲣⲂaggins
    replied
    Originally posted by RealNC View Post
    Don't like the "single-click acts as double-click" thing KDE uses by default? Too bad. You can't disable that through the GUI.
    What's this?

    Leave a comment:

Working...
X