Announcement

Collapse
No announcement yet.

X.Org Server 1.18 Will Require Updated Video Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • X.Org Server 1.18 Will Require Updated Video Drivers

    Phoronix: X.Org Server 1.18 Will Require Updated Video Drivers

    The in-development X.Org Server 1.18 once again breaks the video driver ABI. Rebuilding the driver for compatibility isn't much of an issue for the open-source DDX drivers or the frequently-updated NVIDIA proprietary driver, but it could spell out months of waiting for those depending on the AMD Catalyst driver and wanting to use xorg-server 1.18...

    http://www.phoronix.com/scan.php?pag...1.18-VIdeo-ABI

  • #2
    where is the information about what version of x ubuntu 15.10 will use?

    Comment


    • #3
      Remind me again why it's going to be AMD's fault when Catalyst doesn't work?

      Comment


      • #4
        Originally posted by OneTimeShot View Post
        Remind me again why it's going to be AMD's fault when Catalyst doesn't work?
        Because GameWorks.

        Comment


        • #5
          Originally posted by OneTimeShot View Post
          Remind me again why it's going to be AMD's fault when Catalyst doesn't work?
          Nvidia always manages to get a driver out in timely fashion. If AMD can't, that's on them. They know that the ABI number was bumped today. So when xorg-server-1.18 is released and AMD doesn't yet have a driver that works with it, whose fault should that be, if not theirs?

          Comment


          • #6
            Originally posted by OneTimeShot View Post
            Remind me again why it's going to be AMD's fault when Catalyst doesn't work?
            AMD COULD put out a driver that worked with it if they wanted to. Nvidia does it, they manage to juggle various versions just fine. If Catalyst has a development model that isn't conducive to Xorg then so be it, but it's not like a changing-ABI was something new. The Xorg ABI has been updated 19 times prior to this and it will be updated many times more in the future. Whether they support it or not is entirely up to them, but everyone -else- supports it so it's not like they have much pull or say.

            Comment


            • #7
              Originally posted by johnc View Post
              Because GameWorks.
              With GameWorks a case could be made that it is a blob where only NVidia knows what is going on.

              With the X server however (and kernel too), it is all open source, so the GameWorks excuse doesn't apply here.

              The current AMD driver doesn't even support Kernel 4.0 which was released more than 3 months ago, and the change which broke it was committed sometime in February.

              Comment


              • #8
                Dammit Xorg

                AMD just added support for 1.17 few days ago.
                JUST FEW DAYS AGO!
                FEW DAYS AGO!

                Why did you have to make me add another unnecessary Xorg Repo??

                Comment


                • #9
                  See thats one of the reasons, the "public" HATES the Linux ecosystem. Nothing NEW or GOOD was added, but all drivers stop working for no reason just because some monkeys broke ABI, and this happens LIKE 4 TIMES a year. Will Wayland also regulary break ABI compatbility?
                  Last edited by gotwig; 18 July 2015, 05:10 AM.

                  Comment


                  • #10
                    @yash: You should instead direct your anger at AMD and ask them why the eff did it take them until a few days ago to add 1.17 support. 1.17 was released released 5 months ago. And the ABI was bumped several months before that, in October 2014! So it took AMD from October 2014 until a few days ago to release an approriate driver? Wow!

                    @gotwig: Incorrect, it's not "all drivers". The open ones will soon get updated if they aren't already (the Intel one is). And Nvidia's next driver release, which will very likely happen _before_ 1.18 is released, will have support too. So change your "all drivers" to "Catalyst".
                    Last edited by Gusar; 18 July 2015, 06:15 AM.

                    Comment

                    Working...
                    X