Announcement

Collapse
No announcement yet.

XAA In X.Org Has Finally Met Its Executioner

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gusar
    replied
    Originally posted by Pallidus View Post
    I believe that XAA no longer functions and there is no way to turn it on ... you might as well delete it.
    They *did* delete it! xorg-server-1.13 no longer has it. Why are you so obsessed with it when it hasn't been accelerating anything since 2008? Use shadowfb.

    Leave a comment:


  • Pallidus
    replied
    This forum should really allow edits up to 24 hours.


    Anyway I booted knoppix using both ' knoppix nomodeset ' and ' knoppix radeon.modeset=0 ' and the results were the same

    You are given a non accelerated driver BUT with compiz and composite enabled... this means everytime the window goes into cubes or fire it lags like all hell and it crashed a couple of times just by using the root shell.

    I managed to edit

    Option "AccelMethod" "XAA"

    and # "XAAnooffscreenpixmapsetc"

    restarted it and nothing changed, same lag etc...

    I did several attempts by # and un# pageflip

    I tried Option "XAA" in case they had changed the syntax like the others

    starting getting desperate so I renamed xorg.conf to see if it would auto generate a better one, it did generate a new one but it was the exact same as the old one

    I then un# autodetect and it would detect my driver as some "FBdev" I then manually edited it to

    Driver "radeon"
    Option "AccelMethod" "XAA"

    but it wouldn't even start X


    Don't want to give up but it's pointless, I'm sure there are lots more people with these radeon cards out there someone surely has found a way to enable XAA if it is at all possible

    I believe that XAA no longer functions and there is no way to turn it on ... you might as well delete it.


    I leave a tip for people with these cards:

    I made a glitch in one of my attempts to boot knoppix and used

    knoppix radeon.modeset=o instead of =0

    by using the letter instead of the number it actually boots you into a X without acceleration AND without compiz and composite, meaning the best option to use X... trouble is while booting the screen gets all fuzzed up and strange like a broken TV (never seen that in a computer screen) but the desktop works fine and saves you the trouble of setting rootpasswords and nanoing xorg.conf
    Last edited by Pallidus; 08-29-2012, 05:07 AM.

    Leave a comment:


  • Pallidus
    replied
    radeon.modeset=0 before booting and then adding that accel line "xaa" on xorg.conf

    will try it tonight and see if it works

    also will delete that infamous xxanooffscreenpicies etc etc
    Last edited by Pallidus; 08-28-2012, 06:03 PM.

    Leave a comment:


  • agd5f
    replied
    Originally posted by Pallidus View Post
    Still I wish people would have kept that XAA enabled driver from back in 2008 and rebranded it as 'legacy_radeon' or some such.
    The old XAA code in still in the current release of the driver. It hasn't changed since 2008. You just have to disable KMS to use it.

    Leave a comment:


  • Pallidus
    replied
    brigdman I don't really think you need to be that versed in linux in order to see that it's impossible to revert back to XAA in a 3.X kernel distro...

    Now, I finally see that given things as they are, you might as well delete XAA altogether as it serves no purpose.

    I doubt anyone will bother turning off KMS and XAApixmapsblabla etc etc and all that work that it entails...


    As it stands with the RS200 and I gather the previous and next generations of radeons you can run a lightweight DE like lxde and openbox if you turn the NoAccel option on, you can forget about compiz, unity, 3dgames, etc etc etc... at least you won't get lagged and dragged while scrolling down a simple menu or website as you do with Exa on.


    Still I wish people would have kept that XAA enabled driver from back in 2008 and rebranded it as 'legacy_radeon' or some such.

    Leave a comment:


  • agd5f
    replied
    XAA does not work with KMS. You need to disable KMS if you want to use XAA. That said, as was mentioned here previously, since XAA offscreen pixmap support was disabled years ago, it ends up being roughly the same as shadowfb (NoAccel option in the driver).

    Leave a comment:


  • bridgman
    replied
    Originally posted by Pallidus View Post
    I first tried to create a Option "AccelMethod" "XAA"

    ...

    I unquoted "NoAccel" and lo and behold scrolling windows of text no longer dragged or lagged, glxgears in the little window was 90fps and lxde was finally a little snappy. I haven't tried watching videos or going online, I noticed they had a CUPs bookmark in the iceweasels and that page no longer dragged or lagged like it did.

    ...

    So yeah I was right, this is definitely a acceleration issue and the performance you get now is nothing compared with opensuse 11/ubuntu 8 where you pretty much could have a million windows open etc etc and never lag or drag.
    I don't follow the logic here. You know XAA hasn't actually been dropped in any distro yet, right ?

    If XAA isn't helping then what do you think the acceleration issue is ?

    Leave a comment:


  • Pallidus
    replied
    It doesn't allow me to edit the above thread sorry here's a double post:


    ubuntu/fedora/opensuse/etc... don't give you root access from a live cd session, there are a few which do: knoppix, porteus, pup dog linux, etc...


    I picked knoppix 7.04 as it is the one with the most recent kernel (3.4.X)

    The old HP laptops are in storage and I didn't have internet access there so I just wrote down the terminal codes in a piece of paper and unfortunately I forgot the ".d" at the end of this code

    mkdir -p /etc/X11/xorg.conf.d

    so it said it already had a xorg.conf and to speed things up I decided to nano it and it worked.

    There are a bunch of "Options" that are - # in the display section, mostly to do with hw_cursor and pageflips etc... but I saw what interested me was the

    # Option "ShadowFB"

    # Option "NoAccel"

    I first tried to create a

    Option "AccelMethod" "XAA"

    but I restarted and everything was the same.

    so I tried to unquote shadow FB and restart, again everything was the same.

    I unquoted "NoAccel" and lo and behold scrolling windows of text no longer dragged or lagged, glxgears in the little window was 90fps and lxde was finally a little snappy. I haven't tried watching videos or going online, I noticed they had a CUPs bookmark in the iceweasels and that page no longer dragged or lagged like it did.


    Only downside is that the CPU graph seemed to be showing much more activity simply by opening the file manager and scrolling around etc...



    So yeah I was right, this is definitely a acceleration issue and the performance you get now is nothing compared with opensuse 11/ubuntu 8 where you pretty much could have a million windows open etc etc and never lag or drag.

    Still at least lxde and openbox should prove usable, I'm going to keep windows for offline and run the knoppix live cd to go online, I figure it is a compromise but it's better than installing ubuntu 8
    Last edited by Pallidus; 08-28-2012, 05:44 AM.

    Leave a comment:


  • Pallidus
    replied
    Thanks I will try it with a few distros...

    Live cd session in fedora doesn't allow you sudo privileges I will check ubuntu, knoppix and opensuse

    Leave a comment:


  • Ansla
    replied
    Easiest way would be:

    1. boot your favorite live cd like you do normaly
    2. open this forum thread in a browser
    3. open a terminal
    4. in the terminal paste the following
    Code:
    sudo mkdir -p /etc/X11/xorg.conf.d && sudo nano /etc/X11/xorg.conf.d/radeon.conf
    5. if no error occured you should see the nano window saying [New File] at the bottom
    6. paste the text from the first code section in Gusar's post
    7. exit nano by pressing CTRL + X and answer Y then press ENTER to save the file
    8. hit CTRL + ALT + BACKSPACE to kill the x server
    9. at this point the X server should restart and you can test the new setting
    10. repeat steps 4 - 9 for the second code block in Gusar's post

    One problem you might encounter is that the live cd comes with an existing xorg.conf file containing a Device section, you can check this by doing a
    Code:
    grep -r "\"Device\"" /etc/X11/x*
    and in that case edit the existing file and replace the Device section.

    Leave a comment:

Working...
X