Announcement

Collapse
No announcement yet.

Intel 2018Q1 Graphics Stack Recipe

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by xiando View Post
    That's a pretty horrible "recipe" for some of us. I have a laptop with a Intel(R) Core(TM) i7-5500U CPU and
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
    Stick with your distro if you can, they will do a better job of updating the gfx stack. Ubuntu has oibaff/padoka ppas if you want something newer.

    Comment


    • #12
      Originally posted by MuPuF View Post

      Hey, I work with Intel on this sort of topics, could you please write a bug report about it? I will make sure that we investigate it as our Broadwells are working fine with Linux 4.16 for performance testing (no public links, sorry) and IGT (https://intel-gfx-ci.01.org/tree/lin...bdw-5557u.html).
      Turns out it wasn't actually the i915 driver, my mistake. Though it's not that strange I assumed it was, this is the strangest bug I've had the 20+ years I've (ab)used GNU/Linux.

      https://bugs.freedesktop.org/show_bug.cgi?id=106181

      Please explain this, why does having link_power_management_policy set to med_power_with_dipm make X hang immediately when a) redshift is running or b) I press the keys that changes screen brightness on my laptop (see why I initially assumed it was the GPU driver)? This is the new default in Fedora 28 and FC28 kernels 4.16.x. All is fine with max_performance which I now set on this laptop with ahci.mobile_lpm_policy=1 as a kernel boot parameter.

      I can reproduce this 100% every time with earlier kernels too. Please explain. I don't .. get it.

      Comment


      • #13
        Originally posted by xiando View Post

        Turns out it wasn't actually the i915 driver, my mistake. Though it's not that strange I assumed it was, this is the strangest bug I've had the 20+ years I've (ab)used GNU/Linux.

        https://bugs.freedesktop.org/show_bug.cgi?id=106181

        Please explain this, why does having link_power_management_policy set to med_power_with_dipm make X hang immediately when a) redshift is running or b) I press the keys that changes screen brightness on my laptop (see why I initially assumed it was the GPU driver)? This is the new default in Fedora 28 and FC28 kernels 4.16.x. All is fine with max_performance which I now set on this laptop with ahci.mobile_lpm_policy=1 as a kernel boot parameter.

        I can reproduce this 100% every time with earlier kernels too. Please explain. I don't .. get it.
        Congrats for debugging the issue, but I am the wrong person to ask for an explanation... It would be surprising if it was a brownout...

        In any case, I suggested writing a bug report on fedora's bug tracker to explain the situation. Hans will likely have a look at it, and he has the right kind of knowledge in both sata management and graphics.

        PS: Sorry for the delay, I do not get email notifications...

        Comment

        Working...
        X