Announcement

Collapse
No announcement yet.

XWayland 22.1.1 Released - Fixes Some Windowed Apps Stuck To 58 FPS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • XWayland 22.1.1 Released - Fixes Some Windowed Apps Stuck To 58 FPS

    Phoronix: XWayland 22.1.1 Released - Fixes Some Windowed Apps Stuck To 58 FPS

    It's been over one month already since the release of XWayland 22.1 while this morning v22.1.1 was issued with a handful of bug fixes...

    https://www.phoronix.com/scan.php?pa...2.1.1-Released

  • #2
    I had to switch back to X11 because using Wayland (I tried Plasma and Sway) with PRIME (Intel iGPU + NVidia dGPU) causes artifacts when the window redraws below the refresh rate. Easily reproducible with 'strange -f 33 vkcube'. Does anyone know of a mitigation for that?

    Comment


    • #3
      Originally posted by remenic View Post
      I had to switch back to X11 because using Wayland (I tried Plasma and Sway) with PRIME (Intel iGPU + NVidia dGPU) causes artifacts when the window redraws below the refresh rate. Easily reproducible with 'strange -f 33 vkcube'. Does anyone know of a mitigation for that?
      • What NVIDIA driver version do you have? I strongly recommend using latest one (current is 510.60.02).
      • You can try disabling framebuffer compression for iGPU. This thing caused massive artifacts for me like 2 years ago and I spent lots of time finding it.

      Comment


      • #4
        Packages for Ubuntu... https://launchpad.net/~ernstp/+archive/ubuntu/wayland

        Comment


        • #5
          Originally posted by remenic View Post
          I had to switch back to X11 because using Wayland (I tried Plasma and Sway) with PRIME (Intel iGPU + NVidia dGPU) causes artifacts when the window redraws below the refresh rate. Easily reproducible with 'strange -f 33 vkcube'. Does anyone know of a mitigation for that?
          There's no easy solution unfortunately. It's because the nvidia driver doesn't support implicit synchronization.

          Comment


          • #6
            looks like my problem, cant play using nvidia card in prime systems

            Comment


            • #7
              Originally posted by V1tol View Post
              • What NVIDIA driver version do you have? I strongly recommend using latest one (current is 510.60.02).
              • You can try disabling framebuffer compression for iGPU. This thing caused massive artifacts for me like 2 years ago and I spent lots of time finding it.
              I'm on 510.54-11 right now. I'll try upgrading once it's available in the extra repo.

              I got excited for a moment when you suggested that option, but the problem has not disappeared. I checked /sys/module/i915/parameters/enable_fbc to make sure it was disabled and tried it with the option enabled as well, but it didn't make a difference sadly. Thanks for the suggestion anyway!

              Originally posted by MrCooper View Post

              There's no easy solution unfortunately. It's because the nvidia driver doesn't support implicit synchronization.

              Yes I've seen that mentioned by James Jones from NVidia, but why isn't Xorg affected by this lack of implicit synchronization?

              Comment


              • #8
                Originally posted by phoronix View Post
                Incorrect calculation handling led to the MSC ticking at ~58Hz.
                This is why milliseconds should not be used anymore (not for video rates and not for audio buffer sizes as well). It's too imprecise for the exact value of 16 2/3ms.

                Comment


                • #9
                  Originally posted by remenic View Post

                  I'm on 510.54-11 right now. I'll try upgrading once it's available in the extra repo.
                  ....
                  Yes I've seen that mentioned by James Jones from NVidia, but why isn't Xorg affected by this lack of implicit synchronization?
                  - 510.60.02 does nothing for that thing.
                  - it's only wayland/gbm issue.

                  I found two partial solution
                  1) lower display refresh rate (if game fps match display refresh rate problem is gone)
                  2) prevent from load nvidia-drm module or unload it before start DE (break synchro), main problem gone but there is a lot of oridinary vsync stutters
                  3) back to X and wait for NVIDIA move

                  At xwayland issue discussion someone mention that back to eglstream can fix it, but my gnome always fallback to X, with note that eglstream not working for dual gpu setup.

                  Comment


                  • #10
                    Originally posted by frosth View Post

                    At xwayland issue discussion someone mention that back to eglstream can fix it, but my gnome always fallback to X, with note that eglstream not working for dual gpu setup.
                    I just read this issue and the last comment by James Jones at https://gitlab.freedesktop.org/xorg/...7#note_1275874 indicates in some ways how backwards the Linux GPU stack is. It appears that a lot of Linux GPU developers still have their heads (and in effect implementations of software) stuck in an outdated 90's views of how graphics cards/drivers work.

                    Comment

                    Working...
                    X