Announcement

Collapse
No announcement yet.

Sway 1.6.1 Wayland Compositor Released With WLROOTS 0.14

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sway 1.6.1 Wayland Compositor Released With WLROOTS 0.14

    Phoronix: Sway 1.6.1 Wayland Compositor Released With WLROOTS 0.14

    Simon Ser has released Sway 1.6.1 as the newest version of this popular i3-inspired Wayland compositor...

    https://www.phoronix.com/scan.php?pa...and-Compositor

  • #2
    Hmm shame about this release. It skirts what's valid under semver - the newer wlroots requires newer versions of libdrm2 & wayland-protocols than what's available in ubuntu 21.04 or debian experimental, and has a hard requirement on libseat.

    Comment


    • #3
      Originally posted by royce View Post
      Hmm shame about this release. It skirts what's valid under semver].
      no it doesn't. semver is about the exposed API of the application. not dependencies. and honestly I don't believe sway has made any promises about following semver.

      Comment


      • #4
        It is a very old discussion. It is true semver is explicitly about the public api some piece of code offers, but it is also true changing dependencies goes against the spirit of not breaking compatibility.

        Comment


        • #5
          Nice to see the new version also makes way for libseat as a separate, clean room implementation of seat management instead of (e)logind.

          Comment

          Working...
          X