Announcement

Collapse
No announcement yet.

Sway 1.3 Release Candidate Brings Many Changes For This i3-Inspired Wayland Compositor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    xinorom
    Phoronix Member

  • xinorom
    replied
    Originally posted by thelongdivider View Post
    The biggest issue for me is the lack of nvidia support (I need CUDA) . I'm stuck on i3 until that is resolved, but the devel doesn't have interest in working on it.
    You're going to be stuck on i3 for a very long time then. Try buying hardware from an open source friendly company next time.

    Good on the Sway developers for saying "no" to Nvidia's gross shims and hacks.
    xinorom
    Phoronix Member
    Last edited by xinorom; 31 January 2020, 08:04 PM.

    Leave a comment:

  • royce
    Senior Member

  • royce
    replied
    Whoops, missed it. Thank you 👍

    Leave a comment:

  • Michael
    Phoronix

  • Michael
    replied
    Originally posted by royce View Post
    Michael
    Phoronix
    Michael Sway 1.3 just came out as... 1.4. And wlroots 0.10.0.
    This was already covered yesterday - https://www.phoronix.com/scan.php?pa...y-1.4-Released

    Leave a comment:

  • royce
    Senior Member

  • royce
    replied
    Michael
    Phoronix
    Michael Sway 1.3 just came out as... 1.4. And wlroots 0.10.0.

    Leave a comment:

  • Zucca
    Senior Member

  • Zucca
    replied
    Originally posted by Lycanthropist View Post
    Yes, see this issue: https://github.com/swaywm/sway/issues/2966
    Even though it is closed, there is still no solution.
    Looks like the propsed fix was not accepted and thus the issue was closed.

    Anyway I had no idea this problem exists because I use all my displays at 1.00 scaling.
    There seem to be some workarounds but no offical solution yet. :|

    Leave a comment:

  • thelongdivider
    Senior Member

  • thelongdivider
    replied
    Originally posted by aufkrawall View Post
    For good reasons. If you like Wayland and need CUDA, I think there's no way around a multi GPU system.
    The reasons are definitely good, and I'm not blaming the sway developer. I liked Wayland a lot back when my primary pc had a 7970 in it. But I must stick with x11/i3 due to nvidias lack of gbm support.

    Leave a comment:

  • aufkrawall
    Senior Member

  • aufkrawall
    replied
    Originally posted by thelongdivider View Post
    The biggest issue for me is the lack of nvidia support (I need CUDA) . I'm stuck on i3 until that is resolved, but the devel doesn't have interest in working on it.
    For good reasons. If you like Wayland and need CUDA, I think there's no way around a multi GPU system.

    Leave a comment:

  • thelongdivider
    Senior Member

  • thelongdivider
    replied
    The biggest issue for me is the lack of nvidia support (I need CUDA) . I'm stuck on i3 until that is resolved, but the devel doesn't have interest in working on it.

    Leave a comment:

  • Lycanthropist
    Phoronix Member

  • Lycanthropist
    replied
    Originally posted by Zucca View Post
    Lycanthropist
    Phoronix Member
    Lycanthropist, so gui apps that run on XWayland aren't scaled properly if you have set scaling (to other than 1 or 100%) in you wayland compositor?
    Yes, see this issue: https://github.com/swaywm/sway/issues/2966
    Even though it is closed, there is still no solution.

    Leave a comment:

  • Zucca
    Senior Member

  • Zucca
    replied
    Lycanthropist
    Phoronix Member
    Lycanthropist, so gui apps that run on XWayland aren't scaled properly if you have set scaling (to other than 1 or 100%) in you wayland compositor?

    Leave a comment:

Working...
X