Announcement

Collapse
No announcement yet.

High Resolution Scroll Wheel Support Being Worked On For Wayland

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chugworth
    replied
    Originally posted by [email protected] View Post

    If you miss a touchpad, is still possible using one on a desktop. There are some models, like the Logitech T650 or this Lenovo:

    https://www.newegg.com/Product/Produ...6074-_-Product

    Cannot say its guaranteed both work on Linux, but a internet search can answer that.
    I actually own that exact device already. K5923. I've had it for years, but don't ever use it because it's so terrible. They use some bad material for the touchpad surface that your finger doesn't slide smoothly on. And also, it presents itself to the computer as a mouse rather than a touchpad, just like every desktop touchpad I've ever seen. So if you try to scroll with it, the page jumps line by line like it would with a mouse.

    Leave a comment:


  • Danniello
    replied
    Originally posted by blueweb View Post
    Is it possible to disable/enable this high resolution scroll wheel feature?

    I mentioned it in a previous thread, but I think I'm having issues with the scroll wheel ever since the kernel 5.0 update where this was introduced. Occasionally, the scrolling becomes very slow, where it takes 3-8 wheel clicks or significant rotation of the wheel to scroll one step on a page. This started only after kernel 5.0, and it hasn't happened ever since I've booted back into kernel 4.20.

    I can restore normal behavior by turning the mouse off and on again... until the next time it happens, which is typically several times per day.
    It depends of distribution and hardware but in my case (Fedora 29 + Logitech MX Master) Solaar probably resolved issue.

    Probably, because I'm not sure - I installed Solaar (sudo dnf install solaar) and tested it months ago and until recent update to kernel 5.0 everything was OK...

    After update to 5.0 - mouse wheel started to work ridiculously slow.

    I started solaar and I changed "Wheel Resolution" option from "Off" to "On". Rest of the settings I left unchanged (probably...) :

    High Resolution Wheel Invert: Off
    Wheel Resolution: On
    dpi: 1000
    Smart Shift: 16

    Now mouse wheel is working OK on Fedora with kernel 5.0. So if you have Logitech mouse - you should try solaar.

    Leave a comment:


  • M@GOid
    replied
    Originally posted by Chugworth View Post
    When you move from using Linux on a laptop to using Linux on a desktop, the scrollwheel is just awful. Especially without autoscroll. I'm really hoping that high resolution scrolling will fix that.
    If you miss a touchpad, is still possible using one on a desktop. There are some models, like the Logitech T650 or this Lenovo:

    https://www.newegg.com/Product/Produ...6074-_-Product

    Cannot say its guaranteed both work on Linux, but a internet search can answer that.

    Leave a comment:


  • blueweb
    replied
    Is it possible to disable/enable this high resolution scroll wheel feature?

    I mentioned it in a previous thread, but I think I'm having issues with the scroll wheel ever since the kernel 5.0 update where this was introduced. Occasionally, the scrolling becomes very slow, where it takes 3-8 wheel clicks or significant rotation of the wheel to scroll one step on a page. This started only after kernel 5.0, and it hasn't happened ever since I've booted back into kernel 4.20.

    I can restore normal behavior by turning the mouse off and on again... until the next time it happens, which is typically several times per day.

    Leave a comment:


  • Chugworth
    replied
    So high resolution scrolling still hasn't arrived in user-space yet? That's good to know. I was considering buying one of those high resolution mice, but I don't really like the choices. However, it appears that the high resolution support is hard-coded into the kernel on a per-device basis, so it might not be a good idea to wait for the release of some new mouse.

    When you move from using Linux on a laptop to using Linux on a desktop, the scrollwheel is just awful. Especially without autoscroll. I'm really hoping that high resolution scrolling will fix that.

    Leave a comment:

Working...
X