Announcement

Collapse
No announcement yet.

RADV Vulkan Driver Is Prepping For Vega/GFX9 Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Yeah it says freesync_capable but freesync is set to 0. I did restart and set my display to freesync so not sure what thats about. Maybe it doesn't work with tearfree mode on?

    I'll just follow the guide and attempt to enable it manually. I have a custom EDID I will use at some point also because my screen has quite a narrow freesync range by default.

    EDIT: DISPLAY=:0 xrandr --output DisplayPort-2 --set "freesync" 1 //// That seems to have done it for me, nifty!



    PS. Its a bit of a shame VSYNC must be enabled to have freesync working, because it often has considerably overhead&lag for OPENGL.
    theriddick
    Senior Member
    Last edited by theriddick; 02 June 2017, 11:43 AM.

    Comment


    • #12
      Originally posted by theriddick View Post
      PS. Its a bit of a shame VSYNC must be enabled to have freesync working, because it often has considerably overhead&lag for OPENGL.
      Ummm... that's the whole point of freesync.

      Comment


      • #13
        Originally posted by bridgman View Post
        Here are the latest instructions we posted for the hybrid driver. What I'm not sure of is whether they require the amdgpu driver from the hybrid stack as well, will try to find out tomorrow:
        You need the hybrid stack since the current freesync solution was not upstreamable as is. It would be trivial to support on the open source stack however. I think it's just a patch or two for the ddx to call the freesync ioctl when it detects a full screen application.

        Comment


        • #14
          Originally posted by agd5f View Post

          Ummm... that's the whole point of freesync.
          What? Have you used Freesync under windows yet? Its better to set a frame rate cap then enable vsync when freesync is enabled. Try it under Windows! Thats what it should be like for Linux.

          Anyway in saying that even with my vsync setting turned on the fps still goes above my refresh rate for some reason so I can't be sure its actually even using freesync even thought its enabled. vblank_mode=1 btw, still goes above 60fps.
          theriddick
          Senior Member
          Last edited by theriddick; 02 June 2017, 04:09 PM.

          Comment

          Working...
          X