Announcement

Collapse
No announcement yet.

GIMP 2.8.22 Released, Fixes A 10 Year Old CVE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GIMP 2.8.22 Released, Fixes A 10 Year Old CVE

    Phoronix: GIMP 2.8.22 Released, Fixes A 10 Year Old CVE

    It's not GIMP 2.10 or the GIMP 3.0 unicorn, but for those wanting the latest-and-greatest GIMP image manipulation program update, v2.8.22 is now available...

    http://www.phoronix.com/scan.php?pag....8.22-Released

  • #2
    * Yawn *

    Comment


    • #3
      No one gives a crap about non-remote exploits.

      Comment


      • #4
        Might not be a big update, but Solus has it updated this afternoon.

        Comment


        • #5
          Didn't mention the part worth mentioning lol.
          Users on the Apple macOS platforms will benefit from fixes for crashes during drag&drop and copy&paste operations. On the Microsoft Windows platforms, crashes encountered when using the color picker with special multi-screen setups are gone, and picking the actual color instead of black from anywhere on the screen should finally be possible.
          But better than nothing, otherwise i don't know about the update until many months after. So thanks Michael!

          Comment


          • #6
            Slow day today?:-)

            Comment


            • #7
              2007 was 10 years ago.

              Comment


              • #8
                Originally posted by GIMP
                On the Microsoft Windows platforms, crashes encountered when using the color picker with special multi-screen setups are gone, and picking the actual color instead of black from anywhere on the screen should finally be possible.
                That this bug even existed on the Windows version shows just how few people actually use GIMP on Windows.

                I'm too lazy to rebuild my copy of GIMP though, since mine is Gimp 2.9 built against GTK3. And building it was a nightmare.

                Comment


                • #9
                  I'm still waiting for Gimp to get rid of GTK2.

                  Comment


                  • #10
                    Originally posted by Sonadow View Post
                    I'm too lazy to rebuild my copy of GIMP though, since mine is Gimp 2.9 built against GTK3. And building it was a nightmare.
                    I only have to BABL and GEGL from git to be able to build GIMP from git. Far from the most painful things I've build.

                    Hopefully they'll start doing the nightly flatpaks again soon.

                    Comment

                    Working...
                    X